Help! move of large group to another database results in the group missing completely

I grabbed a group with my mouse (let’s call it “Taxes 2020”), drug it down to a group in another database and dropped it. the group had many files and one subgroup which also had many files. (dozens or so; pretty sure less than 200 in each).

anyway now I have an empty group in the destination called “Taxes 2020” with nothing in it at all. I tried undo and redo a few times, no luck. also tried “Verify & Repair Database” but that didn’t help.

I have the source database stored in a folder called “~/Archives/devonthink/Areas.dtbase2/” (dest is Archives.dtbase2 in the same folder)

I see in there a folder called “Backup 2021-05-21 13-17-01/” which is from yesterday.

I also have a time machine backup of my whole computer from yesterday, but I made a bunch of other changes in devonthink today which I don’t want to throw away.

how do I pull the now missing group from that devonthink backup folder? I immediately copied that whole Backup folder somewhere else in case devonthink decides to make another backup and delete it.

Hey :slight_smile: a couple of questions:

  • is “Taxes 2020” an indexed group, or are/were the items contained in the database?
  • was anything reported in the log?
  • did you perform Verify & Repair on both the source and destination databases?

The backup folder you allude to does not contain a backup of your files; it is an internal backup of the database mechanism (i.e. the structure & metadata). That might still be useful, but it won’t contain the items (which I’m guessing will still be there somewhere anyway).

NOTE: You should not mess about in the intervals of a database.

Is anything reported in Window > Log?

internals, I presume

Indeed. The result of bleary-eyed typing sans-glasses.

The items were contained in the database.

Nothing in the log.

I did the verify & repair on both databases.

Also I have the databases synced to my own private WebDAV server and it synced to there already. So when I opened my iPad, I saw the items briefly, took a screenshot, then they disappeared. So I at least have a count of the items in the subgroup and names of a few of the items in the Taxes 2020 group.

searches for names of items from the screenshot is turning up nothing on mac or iphone. searching for anything makes my ipad app crash every time.

ok I have a copy of both the databases from the day before I did this, I’ve copied them from time machine to a separate folder on my mac. can I just open these old databases in devonthink and then copy the files?

If you open them at the same time, you will get Duplicate UUID warnings in Window > Log and sync will be suspended for the database(s) until only one copy is open.

ok, yes, it did warn me about the duplicate UUIDs. I right-clicked on the Taxes 2020 and told it to duplicate it to the Archives database I wanted it in, and that seemed to work, so then I closed the backup copy of the Areas (source database) and all seems well so far.