Help with syncing

I’m trying to set-up a sync between my DTPO on the Mac and DEVONthink To Go 2 on my iPhone.

On DTTG I’ve created the same Dropbox store and under “Locations” I see my database name listed after “Global Inbox”, with the “Remote” as the default option.

I wish to set-up a “shallow Sync” with just my Metadata (note that I’ve also purchased the “Premium features” package) and see all my database groups listed and choose what to download locally and wish to know how I have to proceed.

I tried to switch the option to “Local” but doing this seems that all the database is downloaded because takes many minutes of a spinning wheel but the space on my iPhone runs out before the operation ends. What seems strange to me is that the database on the Mac is 2.78Gb but on my iPhone seems to occupy a lot more space, as there is enough free space (at least 5 GB) before the start of synchronization.

Am I doing something wrong?

  • Marco.

An almost 3GB database would not Sync in a matter of minutes from Dropbox.

Is your Dropbox location set to Download Files: On Demand? Edit the Sync location to check this. If it’s not, then you can’t do a shallow Sync of a database. It starts here.

Thanks Jim,
but where (and when) I can set the option “Download Files: On Demand”?

Now I’m here:


I wish to sync just the “Memex” database, if I switch the option that now is on “Remote” it starts to download the database; I think the whole dabatase because of the size, and if fill up my iPhone…

Open DTTG2’s Settings > Sync: Edit Locations to see the list of Sync locations.
Press the Edit link and touch the Sync location.
You set the Download Files option there.

Flipping the switch is required as you have to import a copy of the data locally.

I checked and is already set on “On Demand”. When I turn the switch from “Remote” the database start downloading, but fill up space on the phone. What seems strange to me is that there is the need to download the entire database (as if you do not want “On-demand”), and the space occupied on the phone is greater than that of the database on the Mac (2,78 GB on the Mac versus >4,48 GB on the iPhone). I thought that by setting “On-Demand” an index was only downloaded, with groups and titles of the notes.

I tried to free some space on the iPhone but without luck, trying to re-synchronize this time on the phone were uploaded 5.18 GB, then it was filled. I still do not understand why an archive of 2.78 GB on the mac increases so considerably on the iPhone. Has anyone had similar experiences?