How can one create a new Project template?

I don’t know anything about scripting - I’m just trying to figure out if / how I can create a new “Project” template. For example, whenever I create a new projects, I create a system of folders and files for it. I’ve already create such a system, replete with some Excel file templates, and some of DTP’s own templates (Task Lists and Phone Notes), and desperately want to save all of it as one “Reporting Project Template.” How can I do this? Thank a bunch!

The simplest method:

Create a folder structure using Finder that looks like this:
Reporting Project Template
----Reporting Project[/size]

Inside the lowest level folder shown above, place your own folder and document structure. It is important to have the folder named “English.lproj”. (The dashes “-” in my example are just to show the hierarchy. They are not part of the names.) So, your hierarchy in Finder should now look like this, for example:
Reporting Project Template
----Reporting Project
------Folder 1
------Folder 2
--------Document 1.rtf
--------Document 2.rtf
------Folder 2[/size]

Rename the top level folder in this hierarchy to

Reporting Project Template.dtTemplate

Finder will warn you that using that extension will make the contents of the file not visible. That’s OK. Finder will think the folder is a package - a type of folder. (To look inside packages in Finder you control-click the package and select the option to “Show Package Contents”.)

Move the template package somewhere inside:

~/Library/Application Support/DEVONthink Pro 2/Templates.noindex

In DEVONthink, select Data > New From Template > Update Templates Menu. That just refreshes the menu. From there, you can create a new instance of the structure in your database by using your new template.

[size=85]---- Addendum ----
DEVONthink templates can be more complex, and there are a variety of approaches. They can include scripts and other features that extend their functionality. The approach explained above is the simplest and seems to fit the OP’s requirements. I based this tip on the structure of the standard template that is found at:

~/Library/Application Support/DEVONthink Pro 2/Templates.noindex/Classifications/Decimal Filing System.dtTemplate

because that template does not involve scripts. In fact, as an alternative to the technique described above, it is easy to merely make a copy of the template, reveal its contents as explained above, and modify it for one’s own use.[/size]

1 Like

I haven’t tried this yet myself… but I will. Looks like the DEVONthink tip of the week to me-nice post korm.

@korm - Thanks so much for detailing your instructions for creating a new project template. I followed your instructions to the letter. I created the template structure, inserted files where needed, converted the parent folder with a “.dtTemplate” suffix, inserted it into this folder ~/Library/Application Support/DEVONthink Pro 2/Templates.noindex and then I selected “Update Templates Menu” in DTP. Everything seemed to be fine, but when I select the template in DTP, it didn’t work. Any other ideas? Thanks! Hope we can figure it out…


I’m sorry this isn’t yet working for you. It’s difficult to diagnose problems with a template without seeing the template. Is it possible to zip and post on a filesharing site (e.g., the .dtTemplate you created so readers can look at it?

Meanwhile, if you

  • Open your template in a Finder window (using Show Package Contents)
  • Open the Decimal Filing System.dtTemplate in a second Finder window
  • Do a side-by-side comparison
  • Make sure you are modeling your work on the Decimal Filing System.dtTemplate example in the Classifications folder – NOT the one in the Registers folder – these are different approaches to template making: the latter approach involves scripting while the former does not. :wink:

you might see differences that could cause your template not to operate correctly. Another possibility is to simply copy the Decimal Filing System.dtTemplate, rename it, and modify the internal folder structure your way.

Thanks for your help with this. I think I followed your instructions, based on your revised instructions. It still didn’t work, though I suspect I did something wrong. I’m happy to post on a filesharing site (I doubt it needs much zipping). Just let me know how and where, and I’ll gladly follow the steps you’ve outlined.

I don’t have a place I can share … but is free and pretty good for this type of thing. Just post it there, get the link, and post the link here.

I believe one can also upload a zipped file to a forum post as an attachment, although I have never tried it myself to see if it actually works.

I know, I know…it’s taken forever for me to put this together and send you the template, but…here it is at last!

When I open the contents of the template, everything shows up perfects. But I still haven’t been able to use it successfully in DTP. I welcome any ideas and suggestions on how best to make it work. Many thanks again…

Over here, the downloaded file (“Reporting Project Template.dtTemplate”) has no content. It’s not a DEVONthink template package, and opening it in BBEdit reveals nothing inside. :question:


It appears on my end. Here’s another link:

Here’s another:

Let me know if that works. Thanks!

Here’s the problem. Box doesn’t support this extension. If you zip the .dtTemplate file before uploading to Box and sharing, it will work.

Got it. Here we go…

Thanks again!

The zip file at the most recent link contains the same empty file that was posted before. There’s nothing inside to work with. A .dtTemplate file should be a package - a type of OS X folder. Inside that package should be the folder and file structure that I described last December. The thing inside the archive is not an actual .dtTemplate package - it’s not any kind of package. Because it’s not a real template, that’s why it doesn’t work. Since I don’t know how that file was created, I can’t help any further. Sorry.

I suggest navigating in Finder to any .dtTemplate file that was installed with DEOVNthink, right click that file, and chose “Show Package Contents”. You’ll see what should be inside a working template and can take it from there.

I think somehow that file got corrupted. This one should work!

Thanks again for your help…

If you look at the instructions in this posting:


You’ll see this

The internal structure matters :open_mouth:

So do this

and the template works

Thanks for your help with this, but…alas it did not work. Am I missing a step? I followed your instructions exactly, but when I went to Data->New From Template->[and selected Project template] nothing happened. Any other ideas / suggestions? Thanks again!