How to access items in DTTG with other Apps?

Thanks for your reply,
but for this, i would not need DEVONthink.

The point is, to search strings and tags in DEVONthink to find an item - and then, of course, you want to do something with this item.
I mean, that’s what people do with DEVONthink, right?

So, this regular way only works when copying a item to another App and then copy it back to DEVONthink, it seems. Not directly on the item within DTTG.

This i quite sad, as it is not a good way for annotating PDFs in Apps like MarginNote Pro, LiquidText and PDF Expert …
Sending those item back and forth is not a good idea, i think.

The item link could resolv the situation, but this cannot be used in the above apps, as it seems.

Is there anything that could help?
Otherwise, i need to rethink for what exactly i can use DTTG in regards to images and PDFs.
It is still a nice container for web archives, sure …

Even as my reply is not yet visible, let me state that I got the information from … think-ios/ where I got the strong impression, that it is not required anymore to bounce items between files!

But it seems hat DTTG is yet lacking a way to just open items directly in other Apps.
Or iOS is lacking this?

When one is required to use the Files App and search items in the data provider of DTTG, this is sure not a practical way at all.

You could try to work around this by moving items within DTTG to a “work” directory, so that you can find them more easy.

But we are still not where I thought we are.

I was just able to use PDF Expert to open a PDF from DEVONthink To Go, edit it in Place (meaning without importing the document to PDF Expert.)

To do this in PDF Expert in the sidebar tap on iCloud, then tape on iCloud Drive in the upper left, Click on Browse at the bottom of that Pop-up then click on DEVONthink To Go (If you don’t see DTTG click edit then toggle DTTG) Navigate to the PDF then you can made edits, when you close the document the changes will be saved back to DTTG.

Some applications do not allow for Open In, from the Document Providing Applications, PDF Expert is one of them. Therefore you need to start the process from within PDF Expert.

You are right, this work fine - IF you can find the PDF in the folders of DTTG.

But the point of a “item database” is to use it´s tagging, labeling and searching features!

I cannot find a PDF in 10000 others files - for this, i had them labeled and tagged and can find them in DTTG!
But from DTTG, i cannot open this file …

As you said, i would need to find it manually in the folders.

And that´s not the point of an “item database” with extensive searching features.

What i am trying to say:

It is quite frustrating to see, how near we are to a working solution!

But it´s still not there :frowning:

At least, this is now a reason to group my files much more - so that i MAY be able to find them in other Apps.

But then, if i need to group them anyway - support for importing zip archives with nested directories would greatly help!

This way, you can import directly with a sorted hierarchy of folders - and then can find them in DTTG over tags (which are the same as groups then) and in other Apps like PDF Expert, you have at least a chance to find your files manually!

Was that understandable?
I tend to not explain good enough, i fear.

I found a workaround!

You can search your items in DTTG and then replicate them, for example directly in the global inbox or a “work” group.

Doing this, allows you to find your items in other apps.

And after working on them, you can remove the replicated item - all changes will be reflected in your original item!

Not fast and easy, but better than nothing!

“Open in Place” is an awesome iOS 11 feature that has been promised to eventually come around to DTTG. I wrote the original request in this thread:

Unfortunately, this request was 5 months ago, so hopefully it wasn’t forgotten…

Any news on that? I read here that editing in-place is possible with iA Writer, but it doesn’t seem to work for me. Can’t see an option for editing in place in the Share menu, and if I try it from within iA Writer (“Other apps” > explore) I either get “Unknown error” when selecting a file or the file selector just vanishes with no message (and no file).

I have the exact same question as above. If I am in DTTG, find a file and want to edit it, I can’t open it from within DTTG into another app to do the edits. If I am already in the other app or the Files app I can edit it, but I want to start from within DTTG. Is this a limitation of iOS or something DTTG can implement?

I am mostly doing this with Pages and Numbers documents.

When you go to the iA library, there is the option „Open…“ below „From other Apps“.
This opens the access to all File Providers!

I know, but when I do that I either get the folder content briefly displayed before seeing a “Content unavailable” message, or I see the DT files, tap on one of them, and get nothing. This doesn’t happen with files in Google Drive, for example. Also, I still don’t understand how to launch iA Writer from within DT to edit in place, instead of switching to iA Writer and dig around the DT folder structure.

That’s a good question.

DTTG i can either Copy to iA Writer or first select „Open in“ (second row) and then Copy to iA Writer.
Both does not seem to work in regards to changing the file and then seeing this changes also in DTTG.

i can only assume that this is a problem of DEVONthink… maybe support can answer this.
DTTG should just open the App with the item link of the file.

This is not necessarily a simple thing to implement. Apps are developed independently, so just because one app offers an option, that says nothing about the ease of implementation for other apps. We are aware of the request and will look further into the matter as time and workload allow. Thanks for your patience and understanding.

Unlike the Mac, iOS has no concept for “opening a document IN app X” but only for “open a document FROM app X in THIS app”.

Thank you for the clarification. Could someone then confirm what the ‘best practice’ would be, in starting FROM DTTG2, and getting it over to another app? Which button is the one to use? I think it’s fair to say that there is a bit of confusion on what the various options do - so any explanation will at least confirm that what is being done is the ‘best’ option (for DTTG2), even if it differs from what is available in other apps.

Therefore, assuming 1.) that is even possible - what are the steps to follow?
2.) If not, then is the advice that it is preferable to start in the ‘other’ app, and grab the file in DTTG2 from that other app?

Option 2 is the correct one, provided the app supports the Document Provider (ie. browsing iCloud locations to open files). Many, but not all do.

Yes. I wrote above that I couldn’t open DTTG documents from within iA Writer on the iPad, but apparently this was because DTTG was locked with Touch ID. I got rid of that, and now I can edit markdown documents which are inside DTTG by using iA Writer. This has been working pretty much seamlessly. You only need to make sure you’re opening the document from within the other app (i.e. use DTTG as a simple file container).

Hope this helps.

Thanks - and I am correct in that if you want to work from DTTG2, then you Copy to the other app, annotate, and then Copy to DTTG2?
The file is then updated to reflect the annotations done in the other app, but a ‘copy’ of the file is then left in that other app, which must then be removed?

Do I understand this correctly?

Yes, and this method is very inefficient and no longer advocated for round-tripping files.

So what is the recommended way to roundtrip starting from finding a file within DTTG? It seems to be, go refind the file in the other app or in the Files app. I’m not blaming DT for this, but it is unfortunate.

This may be pedantic, but when you use another app (e.g., iA Writer) to locate a document stored in DTTG, then there’s no “round-tripping”. You’re just opening a file from its original location, or opening in place.

But yes, if you have very deep hierarchies in DTTG, locating a document using the Files app or Document Provider can be fairly onerous. Apple’s just not giving developers particularly flexible or robust frameworks and APIs to work with here yet unfortunately.