How to change email app. preference in DTPro?

Hi guys,

I’m new around here as I just bought one of the DT bundles a few days ago. I notice in DT Pro pb4 that there’s a script for sending stuff by email. However, when I try to use this function it automatically opens Apple Mail which I despise. I want to use Entourage instead. Is there anyway to change this preference? I didn’t see anything in the documentation about how to do it.

Great software but the documentation, in my opinion, is awful…just my two bits…

It uses the default mailer program you chose, you can change this in Apple Mail’s preferences to Entourage.

Your comments on the documentation are duly noted but not very helpful. We would appreciate it if you can specify why or what is awful about it. Please use the Help > Feedback menu item for this, or post it here. Thanks.

Okay, maybe it’s not really THAT bad…

I tried changing the setting to Entourage in Apple Mail and it didn’t solve the problem. Apple Mail still keeps popping up when I try to use the scripts…

Maybe there should be a setting in DEVONthink preferences to change the default e-mail application? I didn’t see one…

Did you restart DEVONthink?

Yes, I even logged out and logged back in. Still no Entourage. It might be worth mentioning that were was a critical update released for Mac Office a couple of days or so ago. Might be screwing something up.

I should note I’m having the same problem with DEVONagent as well.

In that case I bet your Registry, a.k.a. LaunchServices database, is corrupt. Use a tool such as Onyx or C ocktail to rebuild it and all should be well.

Ah, I forgot about that. I think I can do that suff using MacPilot. I’ll go home and run some maintenance scripts and see what happens. Thanks for the tip.

I ran MacPilot to update and rebuild Launch Services and I also ran ‘repair permissions’ on Disk Utility. None of these helped my problem. Apple Mail still pops up even with Entourage set as the default mail reader in its preferences.

Any ideas?

DEVONthink asks the system to return the default application for the “mailto:” URL and uses the appropriate script for that application. If that doesn’t work then something is not set properly on your computer. You could for a test type something like:

Select this and go to the Services > Open URL menu. Until that opens Entourage you’ll know that something isn’t set correctly somewhere.

When I copy this, ‘Open URL’ is greyed out in both Entourage and DEVONthink. I can’t access that command at all.

I specifically wrote select and not copy. The Services menu only works on selections.

Okay, I selected it only and no ‘Open URL’ command appears in services menu. Also, if I copy and paste your code into a DEVONthink page, the ‘Open URL’ command does appear and it brings up Entourage.

When you open the Mail Import window using File > Import > Email, does it display the contents of your Entourage mailbox list?

I too am having this problem;

I have ensured that the Mail app preference is set to Entourage, tried the select all - services open url (opens Entourage), rebuilt the LaunchServices database, reset file associations and restarted DevonThink Pro. When I select Import Email both the Mail and Entourage databases are displayed (in that order).

Any other suggestions?

Good app so far, just a few more clicks than I would prefer so far.

No idea, we read that information from the Launch Services database and nowhere else. It should display all supported and availble mail applications and by default display the contents of Entourage in your case.

Maybe I was not clear in my post. I can see the Entourage application when I select Data Open with - Mail (default) Entourage is available. I would like to be able to use the keyboard to select and not have to click through the menus.


In that case you will need to change (in the Finder) that files ending with “eml” always have to be opened with Entourage. Then the default will be set to that and you can use the keyboard shortcut.

I have to say that I am very pleased with the response time on my questions.

I have as yet not solved my problem.

Here were the latest steps I took;

Shut the computer down.
Rebuilt the launchservices database
Lunched Mail and changed preferences to Entourage
Shut down Mail
Right clicked on a .eml message, verified Open With was Entourage default OK!
Launched Entourage
Launched DevonThink Pro
Data Open With still shows Mail as (default).
Tried keyboard shortcut - opens Mail
File Import Email - Mail Source defaults to Entourage

Any other advice?


That sounds like a bug to me. Christian can answer that, I’ll notify him.