how to inset a row in a table

I just started to test out devonthink for Mac a couple of days
ago. So far, I find it very helpful in what I wanted to do with it.

Yesterday, I was stuck with below issue.

I first created a Rich Text note
and in it I created a table of 4 columns and 5 rows of data.

Later, I wanted to insert a new row after the 2nd row.
I could not find a way to do this.

Could you tell me if there is a way to do this ?

HP Wei

DEVONthink uses the somewhat minimalistic RTF table widget that OS X provides (See Format > Table). It is not possible to insert a row inside the table – insertion only occurs at the end of the rows or columns, as the case may be.

To do what you’re looking to do, open the RTF externally (Data > Open With) in a more feature-rich RTF editor – Pages, Word, Mellel, Bean, Nisus, etc.

Thanks for the info.

I tried the method “Data -> Open with”
with three of your recommendations to edit a table in a RTF:
bean -> works OK
melle (trial version) -> it always saves the modified
rtf file to a directory on the Mac.
For bean, after clicking ‘Save’,
the display in DevonThink (DT) shows the
updated content.
Pages -> not tried after browsing Apple’s web site.
It says it could not save to rtf.

Also tried Ominoutliner (OL) for the imported .oo3 file:
–> I can edit the content by OL and click ‘save’ and DT shows
immediately the updated content.
DT displays the Date Column incorrectly.
7/30/2015 in OL shows up as M/d/yy in DT
This may be a known problem ?