How to remedy the incorrect indexing of desktop

I have a database that indexes desktop files, and one day I inserted a 1T removable drive with over 300g of data.

After that the software always got stuck opening this database and had to force quit with the activity monitor.

Checking the activity monitor, I found that this database occupied 400g of virtual memory, so I guess that Devonthink indexed the files in the hard disk during the time when the 1T hard disk was once used.

How can I solve the problem? I don’t have a backup of this database, there is a subscription data file in it, which is very important to me.

I’m looking forward to hearing from you all!

Please try this to restore an internal backup of the database:

  1. Select the database in the Finder, choose “Show Package Contents” in the contextual menu
  2. Copy (!) the most recent Backup folder to the desktop
  3. Copy (!) the Files.noindex folder into the copied (!) Backup folder
  4. Add the file extension .dtBase2 to the Backup folder

Now you should be able to open the copied Backup folder by double-clicking on it. Afterwards use File > Verify & Repair Database to ensure that everything’s fine.

If this should fail, then repeat the above steps using an older Backup folder.

1 Like

In addition to @cgrunenberg ‘s post: set up a regular backup with Time Machine or some other mechanism. Not having a backup of important data is a bad idea.

1 Like

Problem solved! Thanks a lot!!!

Thank you for your remind. I am in the process of backing up files and setting up the time machine now. You are right! The habit of not backing up important files will waste a lot of time and energy if something wrong happens.