I cannot change or add an Author to PDFs

This is new, within the last few months. Previously I have had no problem, and I have no idea what is different. I have read many threads about related problems and tried many things. This is affecting all PDFs, at least all of them that I have tried (which is, probably, in the hundreds).


Brad G


This should be possible via Info > Properties but only if there’s a preview of the PDF document.

Thanks, that has been my standard practice, and it has stopped working. in particular, i can enter something into the author box, but it won’t stick. even if i update the database records, it doesn’t stick

Which version of macOS and DEVONthink do you use? A screenshot after entering the author would be useful too, thanks.

on MacOS Big Sur, I followed the devonthink UG and went in and changed the forced edit preference for PDF. also on finder i made sure files were not locked.

btw, sorry for the delay, holidays, etc.

Hi, I just wanted to check if there is something else I can try?

Should I try a re-install of Devonthink?



Reinstalling is rarely the resolution to an issue and usually does nothing more than remove useful troubleshooting data.

Also, just using the hidden preference is not a magical key. It all depends on the documents in play.

Zip a problematic document. Start a support ticket and attach the zipped file. Thanks!

1 Like

Thanks. I just opened a new ticket and attached a