I Found A Problem Using TImeMachine For Backup DT-Databases

I had to restore a DevonThink-database and found a big problem: You cannot use TimeMachine for backing up DT-databases. If you do so, you will be disappointed because the restored database contains only links to the files you have stored in your database. The files itself get lost.

I even couldn’t find the files in d´the restored database when I opend the package of the database and looked under “files”. It was empty! Fortunately once a week I still make backups with iBackup and so I could restore the database with iBackup and hadn’t lost too much informations

I hope this problem will be fixed an the structure of the database will be redesigned for using it with Leopard. In the meantime you should be careful uing TimeMachine for backing up DevonThink Databases


Time Machine only backs up exactly what is on your disk. And when you restore a database that has links to external files (indexed files) and you don’t restore them, well, they’re simply not there. But when you import files and restore a database everything will get restored as expected.

That’s strange. My current main database was recovered from Time Machine, as I had decided to experiment with that. Before I switched to the database as recovered from Time Machine I had recorded the information for the database from Database Properties and had checked the number of files in the internal Files folder as well as the total size of the Files folder.

Note that my database is almost totally self-contained (Import-captures from the Finder). But I had several Index-captured files, and the paths to those external files in the Finder still worked. Obviously, I hadn’t deleted any of those external files, or the paths would have been broken.

The copy of the database pulled from Time Machine backup matched perfectly, and all of the files that were in the internal Files folder previously are in the copy from Time Machine. I had reason recently to review some PDFs captured in 2003, and they were all there.

I had gone for about 3 years without having to resort to a backup. But on November 19, 2007 I was responding to a Support query about a damaged database, and the user had installed an Internet plugin with which I wasn’t familiar. As a test, I installed it on my computer. Result: a blown database.

Before doing that, I had a current internal backup and a current external Backup archive as well as a current Time Machine backup. The Time Machine backup is working well for me.

But your experience is a cautionary one. Before trusting a Time Machine backup, check Database Properties and look at the Files folder. Note: Is it possible that your database had been somehow damaged prior to that particular Time Machine backup? You might try taking a look at an earlier Time Machine version of your database.

Hi Eric…

…ok - but I expected that the restored DT-database will recognize the links to external files because the linked files hadn’t changed.

And the restored DT-database couldn’t rebuild neither external link nor imported files. Most of my files are imported files and they get lost - the internal files folder of the database is completely empty


Hi Bill…

…I just checked the database in the structure of my TimeMachine-backup. I looked for the internal files folder and i found all my 3061 objects. But it ist not possible to restore the database. If I do so, i get an restored database and its internal files- folder ist empty. I just tried it with a new test-database.

Actually: I get the same problem when i go to the time-machine structure and copy (not restore!) the database zo my desktop. But I have no problems when I do so with my “normal” backup I build with iBackup.

That seems a little bit strange and there might be a problem between TimeMachine and DevonThink. I will be carefully…

I just could reproduce the problems I described once more…

I suspect it is a problem when I have a DT-database open and TimeMachine attempts to make a backup in this time. That might the cause for the the problem, but I’m not sure. Perhaps anyone made the same experiences.

I really don’t trust TimeMachine…