I split my database and now DT can't locate the files

I was experiencing lagging because my data base was too large. I split it, but now when I’m in the new data base, while i see the file icon, when I try to access it, it tells me there is no file…


I can find the files as DTP files in finder, but when i try to open them, the same thing happens.

Could you post a bit more info – such as: how did you “split” the database - what steps? What you mean by “I see the file icon”? Before the split, were your documents imported or indexed? Did you save a backup copy of the unsplit database?

DEVONthink not finding a file with a message like in the following image is frequently a case of an indexed file gone missing in the filesystem, or the path is incorrect – in that case, you’d need to do File > Index again, starting from (new) location in the filesystem.

I did this:

  1. Create a new, empty database and give it an appropriate name. In the original database, select the content that’s to be moved to the new database and then Control-click (right click) on the selection. Choose the contextual menu option, ‘Move To’ and select the new database as the destination.

I see the file name in the new data base, but it links to no file. when I look for it in finder, I see that something is stored a few layers down, like this: Library>Cache>Metadata>devontthinkpro>a_very_long_number>a short number>the file

before the split the files were imported. I did not save a back up.

going through the 1000s of documents and indexing them again sounds like a tedious way to spend the day, but I can’t find where they are, since they’re not indexed, they were imported…

That procedure should work … except, did you select a destination group in the new database, or just the name of the database? If the latter, maybe there are documents in the “Top Group” – select Go > Top Group — is there anything there?

Do you see error messages such as the one in the image I posted above?

When you look for the file in Finder, it is showing you the location of the Spotlight index cache for that database. That’s an artifact of turning on Spotlight indexing for a database, and it isn’t the file you are looking for. However, if you double click one of those files you found, it should open the file in the database. Does it?

Yikes. :cry: Sorry. How about Time Machine?

The question about indexing was just a data point … I wouldn’t suggest you need to reimport, unless we can’t find your files …

Nothing in top group.

No error message.

When I find it in finder and double click it opens to the same “no file” message.

Yes time machine, but can I restore and old save, recover the files in devonthink, w/o affecting any other data?

so looking into Time Machine, how would i simply lose the new data base w/o affecting any of the other databases?

Have you tried Tools > Verify & Repair?

If not, then do a V&R. If that is not successful, then try this: close DEVONthink. In Finder, navigate to folder with the database that is reporting “no file” messages. Control-click the database and from the contextual menu that pops up select “Show Package Contents”. Inside the database package you should see a folder named “Files.noindex” with many subfolders. Being very careful not to move or delete anything, browse through those folders, which should contain all of the original files in your database. The subfolders are arranged by file type, so you should be able to quickly determine if one of the files that is shown as missing is or is not inside the database.

You might want to consider contacting support-at-devontechnologies.com directly for more personalized help then the forum can provide. I see no reason in what you’ve described for your documents to be missing, so obviously it’s me that’s missing something :open_mouth:

If your Time Machine backups pre-date your database split, then the old, unsplit database might be recoverable. Just go into Time Machine, navigate back to a date when the pre-split database still existed, and restore it to a location other than the location where your other databases are stored. (Say, to the desktop.) Close all the other databases in DEVONthink and then open the restored database from your desktop. If that successfully gets your back to the pre-split state, then you can try again. This time I’d suggest creating two NEW databases, and drag the documents and or groups from the unsplit database into one or the other of the new databases:

Okay. I’ll try it. I’ll have to restore the orginal data base, which i pulled the new data base from, therefore will lose any changes I’ve made to the old one since the backup. Which is only a minor annoyance. or is there a way through that?

Tried it. No luck. The recovered data base does not show the lost folder, filled with files but nor does it show the documents I’ve added since that back up. So it’s got things half right.

So, again, I tried to recover from even earlier and the folder with my precious files does not appear in the recovered version, but the new files added since then do not appear either.

Any other thoughts? How can 1000s of books just vanish?

A while back I was advised to import as opposed to index, which seemed a bit sketchy since it made it tough to access the documents other than through devonthink and it made it tough to share them. i had to pretend to email them, grab the file and drag it to my desk top. Now after this experience it makes even less sense. Devonthink is not for people who don’t have a deep knowledge of computers. I’m no neophyte but generally don’t spend too much time staring at my Activity Monitor unless I’m sorting out a Devonthink problem. Now I’m stuck with all these files - even the ones that I can actually find- in this preposterous devonthink format that I can’t do anything with.

I want to get all the pdfs i do still have the heck out of this format and back to pdf so I can find some better, more stable software. How do I do that?

feeling pretty annoyed right now…

  1. Where are you databases located?
  2. Does this persist after rebooting your machine?
  3. The cache files are not your DEVONthink files.

Also, pp.93-94 of the DEVONthink Pro manual has the steps for misbehaving databases.

  1. Tools > Verify & Repair
  2. Tools > Restore from Backup
  3. Tools > Rebuild Database…
  4. Manual recovery from TimeMachine, etc.
  5. Call for help