iCloud Sync error (CloudKit)

Same problem here since 5 days: “Request failed with http status code 503 CKErrorDomain 6” – worked for months without any issue before (database 3 GB). Switching to Bonjour until solved.

Please…

  1. In DEVONthink’s Help menu, select DEVONthink 3 Help > Documentation > Appendix > Hidden Preferences.
  2. If you’re on macOS Catalina or earlier, click the On link for SyncDebugLog.
    If you’re on macOS Monterey, ​Control-click​ the ​On ​link for ​SyncDebugLog​. Paste the URL into Safari’s address bar and okay opening DEVONthink.
  3. Quit and relaunch DEVONthink.
  4. Manually initiate a sync of a database.
  5. Add a file to the database, select the database in the Navigate sidebar, and manually sync via File > Synchronize.
  6. In DEVONthink, hold the Option key and select Help > Report Bug.

Thanks.

Thank you. Done & sent.

I am having the same problem; it seems to have started a couple of weeks ago. I get an error about a missing manifest file when I try to sync using CloudKit:

12/10/21, 4:17:09 PM: iCloud (CloudKit)	File "660808343.836-080aa086f6f16f36427dae2913d3b6aa2f97d774-3627876937.manifest" missing of database "Inbox".

and many other similar messages.

I have switched to Bonjour for now, but of course that doesn’t work when I leave the house.

Is there anything I can do to help debug the problem?

Perhaps try another third party sync service? Or talk with Apple about debugging their CloudKit service? I’ve seen some recent discussion on this topic at Mac Power Users forum.

1 Like

I tried the procedure to do a fresh start on CloudKit, found here, but I kept seeing 503 errors on the Mac when I tried to sync my first database, and when I tried to sync on the iPad, it didn’t see the database at all.

So I went back to Dropbox. It works.

1 Like

I have the same problems with iCloud:

a) Request failed with http status code 503 CKErrorDomain 6
b) … 937.manifest" missing of database “Inbox”

Is there any solution / work around available in the meantime?

See Sudden loss of ability to sync - #12 by cgrunenberg

@Skylax I experience the same problem, did you find a solution yet?

Probably have to wait till Apple’s cloud service kicks and decides to work again. Under their control, per @cgrunenberg’s post just above yours.

Disappointing from Apple … I did switch to Bonjour and synching is again fine.

1 Like

At the moment I can’t sync at all with my equipments

  • iMac
  • MacBook Pro
  • iPad
  • iPhone
    I deleted the app completely from my iPhone and reinstalled it. No sync, failure message … CKErrorDomain 6 …
    When looking to my databases I think something happened around Jan. 13th. Until that date it seems to be working.

@devonthink

Did you get in contact with Apple regarding this iCloudKit syncing problem and what are the results?

1 Like

As has been noted before (several times): Apple is in control of its Cloud services, no other company has any influence on that. There are sync services for DT that work a lot more reliably, notably Bonjour and WebDAV.

2 Likes

And Dropbox too since version 3.8.

Now it becomes clearer that’s not a pure DevonThink sync issue, see (in German):

Thanks so much for this follow-up. There is indeed buzz about CloudKit being broken on other sites as well. Ugh, Apple! :slight_smile:

Ts. They’re busy working on so many things like digital hubs, home automation, self-driving cars, automation …wait, no, not this one, collaboratively working on the same documents, a macro language for Pages and Numbers … no, again, not this one.

How could they possibly find time to fix something that was always broken like iCloud?

How could they possibly find time to fix something that was always broken like iCloud?

Or (avoiding expletives) PDFKit. :rage:

1 Like