iCloudKit Sync failled with CKErrorDomain 4-Message

Since the introduction of iCloudKit-Sync I used to work very well with it. Suddenly last week it occurs that two databases stopped synchronising with the message: »Saving asset failed« because Netzwerkfehler (CKErrorDomain4). Other databases seems to work as fine as it should. There are no problems when synchronize the databases to MacBook via Bonjour.
Is there somebody in the forum who can give me a help?
I have rebooted the System several times, also cheked the database for Integrity with no success, always the same issue.

You’ll find lots of posts here about issues with Apple’s CloudKit, and this particular error “CKError Domain 4”. “CK” means CloudKit. Search here for that error message or with your favorite internet search engine to see what Apple says in case you have not contacted them.

Me: I don’t use Apple CloudKit to avoid all these issues.

1 Like

Im getting this error all the time, usually when my MacBook was closed/asleep, so I always interpreted them as signs that DT tried to sync before MacBook re-established connection to wi-fi. For example right now:

But all my DBs are synced despite the error in the log. Do you actually see some persistent issues, not-synced states between your different devices using CloudKit for syncing?

On the synced devices (iPhone, iPad) I’m missing some files which were not synced. It is a problem with 2 of 4 DB. The internet connection works well, since in the same time sync runs wiith two other DBs. I think that’s strange.

  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it. What does it report?

Now looking on the DTTG, there is no triangle after syncing, but the message occurs on the DT on desktop permanently. But yesterday after sync on DTTG ther was a triangle the same Message with CKErrorDomain 4. Saving asset failed. strange!

CloudKit has been obnoxiously unreliable in the past few months, with more than one outage reported.
As we’ve often said, if you don’t need a remote sync option, we suggest you don’t use one.

Thanks for the tip, it is a pity that such an error occurs, so far everything has worked fine. I will probably switch to Bonjour.

it is a pity that such an error occurs

We agree, but it’s beyond our control despite our best attempts to minimize the effects.

I continued to get the CKErrorDomain 4 all the time. Internet is working fine. Other apps sync via iCloud. I went back to iCloud legacy syncing which works (at least for now…)

Note iCloud is not the same thing as CloudKit. CloudKit is a specific facet just as iCloud Drive, Photos, etc. are.

I appreciate that, but I don’t understand why I get so many sync errors with Devonthink (‘couldn’t upload xxx pending files’, ‘error saving record’, ‘AsyncsocketErrorDomain’, etc.). I never get a sync that just works. I’m sure Devonthink is more complicated than e.g. Bear but Bear just syncs fast, no problems…

CloudKit has not been reliable for many people - users and developers - in the past several months.

The Async error has to do with Bonjour. Do you have Bonjour enabled on more than one device?

And Bear is definitely not doing the same thing sync-wise.