iCloudKit Sync failled with CKErrorDomain 4-Message

Hello
Since the introduction of iCloudKit-Sync I used to work very well with it. Suddenly last week it occurs that two databases stopped synchronising with the message: »Saving asset failed« because Netzwerkfehler (CKErrorDomain4). Other databases seems to work as fine as it should. There are no problems when synchronize the databases to MacBook via Bonjour.
Is there somebody in the forum who can give me a help?
I have rebooted the System several times, also cheked the database for Integrity with no success, always the same issue.

You’ll find lots of posts here about issues with Apple’s CloudKit, and this particular error “CKError Domain 4”. “CK” means CloudKit. Search here for that error message or with your favorite internet search engine to see what Apple says in case you have not contacted them.

Me: I don’t use Apple CloudKit to avoid all these issues.

1 Like

Im getting this error all the time, usually when my MacBook was closed/asleep, so I always interpreted them as signs that DT tried to sync before MacBook re-established connection to wi-fi. For example right now:

But all my DBs are synced despite the error in the log. Do you actually see some persistent issues, not-synced states between your different devices using CloudKit for syncing?

On the synced devices (iPhone, iPad) I’m missing some files which were not synced. It is a problem with 2 of 4 DB. The internet connection works well, since in the same time sync runs wiith two other DBs. I think that’s strange.

  • Is there a triangle on the sync icon in DEVONthink To Go’s bottom toolbar? If so, touch it. What does it report?

Now looking on the DTTG, there is no triangle after syncing, but the message occurs on the DT on desktop permanently. But yesterday after sync on DTTG ther was a triangle the same Message with CKErrorDomain 4. Saving asset failed. strange!

CloudKit has been obnoxiously unreliable in the past few months, with more than one outage reported.
As we’ve often said, if you don’t need a remote sync option, we suggest you don’t use one.

Thanks for the tip, it is a pity that such an error occurs, so far everything has worked fine. I will probably switch to Bonjour.

it is a pity that such an error occurs

We agree, but it’s beyond our control despite our best attempts to minimize the effects.