Image scripts not working?

It seems the Images Scripts are not working? I often resize images down to 1024 pixels, but this does not work in DT3.

Tried the other Image Scripts as well and none seem to work?

Is DEVONthink 3 allowed to use Image (see System Preferences > Security > Automation > DEVONthink 3)?

Yes it is.

I still have DT Pro Office v2.0 installed - also same permissions - although I have not opened it for a few weeks.

I would recommend to deinstall version 2 as the behaviour of scripts is undefined otherwise - macOS might use one or the other version for scripting.

De-installed V2, rebooted, but still the same. No Image Scripts are working on mine.

Which macOS version?

Sorry - 10.15.1 and DT 3.0.2

Do the scripts work after opening them in the Script (see Applications > Utilities)?

No. I opened them, re-compiled, saved. Rebooted but no change.

A screenshot of System Preferences > Security > Automation > DEVONthink 3 would be useful, thanks.

Any update on this? Is it only my installation, or a bug?

So far we couldn’t reproduce this issue.

Is there a way to maybe uninstall / reinstall all the scripts?

Are there any permissions I could check?

You could try them on a new user account first.

The scripts work on a a different user account on the same Mac.

I don’t know much about user accounts - is it easy to make a new user account and move all my software and settings onto it…?

Generally applications are installed in the root /Applications folder which is accessible to all users on a machine.

However, moving all your data is not necessarily a trivial thing to do.