Import Database fails with "Could not load a record" error

I’m using DTPO 2.7.3 at home, and I’ve been syncing my databases with DropBox. I installed the same version on my new work laptop and tried to import one of my databases, but it always fails with the same error:

9:27:38 AM: Sync: Computing → [my account] (Dropbox) The operation was cancelled.
9:27:38 AM: Sync: Computing → [my account] (Dropbox) Hubble Finds Sign That Habitable Planets Could Exist Beyond Solar System: (Could not load a record (not found ({“error”: “File has been deleted”})))

This morning at home I ran a Verify & Repair on each of my databases and then re-synced them, but am still getting the error. What else might I try?

You need to do a Clean Location.

  1. Open Preferences (Command-,) and click the Sync tab.
  2. Choose a database that is being Synced and the Location you want to clean.
  3. Click the Action button (with the gear icon) and choose “Clean Location…”
  4. You will be prompted that this will delete the remote data. Allow it to proceed. This is SUPPOSED TO happen as you need to Sync with fresh data.

I’ll do that when I get home tonight. That’s been the fifth or sixth time I’ve had to start over with a clean sync since last summer, though. It’s painful to re-upload a few gigs of data each time. :frowning:

I did all that (including the 3GB upload) and successfully synched my work laptop. I noticed there were a bunch of new unread RSS feed articles and I selected Mark > As Read on their group. Then I selected Synchronize and waited.

3 hours later, it’s still in “Committing remote transaction”. At this point I’ve given up. I’m going to make my work laptop’s database read-only, and email myself copies of interesting documents so I can add them at home and push them out. That’s the only reliable way I’ve found to sync my databases.

I went through the whole process again:

  • At home: did a full “Rebuild Database…” in case there was something invalid in there. Deleted my sync settings. rm -rf’ed the directory on the WebDAV server. Added the sync settings back and waited a few hours for my database to be copied up to the server.
  • At work: deleted the database, went into Sync, and used “Import Database…” to download a brand new copy.
  • At work: I have a few RSS feeds that I don’t really read; I just want their contents in DTPO so it can suggest useful stuff to me with “see also”. I noticed that I had about 4,000 unread items. I used “Mark > As Read” on the folder.
  • At work: I selected “Synchronize”. DTPO asked me to resolve conflicts *, and I told it to always use the local data. This ran through to the end, then stuck on “committing transaction” for 6 hours or so. I had to force-quit DTPO to make it stop. I re-ran the sync step and it finished in a few seconds.
  • At home: I selected “Synchronize”. About halfway through the progress bar, it failed with the dreaded “Could not load a record”. Cursing profusely and retrying did not fix the error.

Is there anything there I should’ve done differently? Am I unknowingly sabotaging my syncs? This is a bog standard Apache WebDAV server that I use for lots of other programs (OmniFocus, iBank, etc.). I adore DTPO and it’s absolutely the best information manager I’ve tried (of many!), but this sync thing is about to make me wash my hands of it. I can’t trust it keep my home and work laptops up-to-date with a single database which really limits my willingness to use it more extensively for other things.


I got home and tried to sync again. I got:

7:55:09 PM: Sync: Programming → [my server] (WebDAV) The operation was cancelled.
7:55:09 PM: Sync: Programming → [my server] (WebDAV) Show /r/python: sqltap - SQL profiling and introspection for applications using sqlalchemy: (Could not load a record (Buffer Too Small))

That document doesn’t exist at all on my home system, so there’s nothing I can really do but wait until Monday when I can clean up my work laptop’s database enough that I can resume backups of my home installation. :frowning:

  • My least favorite thing about the synching process. I wish it would automatically apply the most recent change.