Import database from DTG2 into DTG3


Just upgraded to DT3, and was surprised to see that it didn’t automatically carry over my databases from DT2. Is there a way to accomplish this, short of just resyncing?


Was DEVONthink To Go 2.7.x installed with its databases intact before upgrading?

Yes, DEVONthink To Go 2.7.x was installed with intact databases.

Make sure it’s 2.7.9 then try this…

  1. Delete DEVONthink To Go 3.
  2. Reboot the iOS device.
  3. Launch and quit version 2.
  4. Install version 3 and open it.

Does it show the databases in 3 now?

Unfortunately, still the same issue. Definitely 2.7.9.
I tried the process twice, once with rebooting and again with a hard reset of the device.

I should mention that I’m running the 14.5 public beta.

I’m having the same issue.

Are you also running the iOS 14.5 beta?

No. 14.4.

Same thing here as well. 2.7.9, 14.4, WebDAV

Same problem here, 2.7.9, IOS 14.4, WebDAV. The info button (?) of the 3 Version shows 4.19 GB (out of 21GB) but is not changing. This was on the iPad.

On the iPhone (same config) it worked, but there I did not have the very large eMail Database synced.

Same here - on my iPhone everything works fine but not on the iPad. Very strange - same config, and no memory limitations…

I’m encountering the same issue also. iOS 14.14, DTTG 2.7.9

I tried this today with the updated 3.0.2.
But still the strange behavior. It works on the iPhone but not on the iPad.
Any hope with 3.0.3 ?

I’m still encountering this issue, now with 3.0.3. In addition to following @Bluefrog’s steps, I also erased the DTTG data stored on icloud, but that did not seem to help: when I re-installed DTTG 3, none of my databases showed up. I should also add that DTTG 3 shows that it has 120 gb of files; however, none of these files is accessible from the database.

Do you still have DEVONthink To Go installed?

Yes, I have DTTG 2 and 3 installed.

In DEVONthink To Go 3, select ? > Contact Us to start a support ticket. Thanks.

1 Like

Hi. Have this issue been resolved yet?
I’ve the same issue on iPad too. I installed DTTG 3 on day one of its release. I’ve not been using it since then, but keep using DTTG 2. I thought I was my problem so I was just sitting here and did nothing until I find some time to set up the sync stores all over in DTTG3.

So is there a solution so that I don’t need to setup all over in DTTG 3?