Import from Evernote in 2.6.1

The menu item Import/Notes from Evernote doesn’t work for me in 2.6.1. It brings up a list of Evernote notebooks, I select one, the Evernote dock item bounces like crazy, the log window tells me the right number have been imported, but they are nowhere to be seen in my database and the Today smart group reports no change in the number of items.

The files import into an Evernote folder with a subfolder for each notebook.

Check the criteria for your Today Smart Group. They would appear if you are using “Date Added” but not “Date Modified/Created/Opened” (unless you actually modified or opened one).

Thanks, but Date Added or Date Modified makes no difference, and I can’t see an Evernote folder anywhere.

Successfully imported my single three-note notebook (only Evernote content), with the top-level Evernote group icon matching the app icon.

Sounds like you have multiple notebooks, khw. Have you tried importing from any different one(s)?

Thanks sjk. I have dozens of notebooks. The one I have been trying to import is a local one, so I tried a synced one instead and that worked: a nice Evernote group with the green elephant icon was created containing the imported notes. So I then tried to import the local notebook again and that then worked.

I then wanted to see if I could reproduce what I had been seeing, so I deleted the Evernote group in DTPO, and restarted DTPO. This time, no notebooks, synced or local would import. I then happened to look at the Trash folder, and lo and behold it was importing the Evernote notebooks into the folder in Trash! I am not sure whether this is a bug or a feature. Having trashed the Evernote group, I would have expected a new one to be created in my Inbox when I execute the Import from Evernote menu item, rather than invisibly import them into the trash.

Oh, and another oddity is if I drag and drop a single Evernote note into DTPO it copies the note, but if I drag and drop several it creates bookmarks for the notes.

Though it can be classified as a bug (and maybe should be), it’s actually logical behavior. The items in the Trash don’t exist in any real structure - they are still just database entries with some metadata about being in the Trash.

If you are one to use your Trash as an extra filing cabinet, don’t. It’s a bad idea in the Finder and here too. (Not saying you are but I have to say it.)

Thanks. I agree that Trash should not be used as an extra filing cabinet (and I don’t). It would seem a bit bizarre if this behaviour is intended on the assumption that someone might be doing so, because of the unintended consequences for the majority of users who treat Trash as trash.

No, it’s not intended for those using the Trash this way - or as a punishment for those who do 8) . It’s just how databases function. It’s part of the reason why updating indexed items sometimes may not seem to work. There are copies “in the Trash” and therefore are technically “already indexed”. Empty the Trash and the indexing updates.


Nothing happens when I try to import notes from Evernote.