Import mail from Thunderbird

of course: If the integration process works well, as you shared, then that’s great. Less steps, good to go. The solution I shared is a general solution that works across all mail clients, because all of them support IMAP. The setup is actually very straightforward, as the whole thing gets delivered in a docker container, to which you then connect your different email clients. Also, people were suggesting copying text or using pdf - which I feel is much inferior to having the actual mails in DTP.

This is a great script - thank you Pete31. Question: the path prompt appears and vanishes rather quickly, then the message goes to my inbox. I thought I would have control via the path dialog box?

-Steve

That’s how it should be. The script imports to DEVONthink’s global inbox.

No, that’s not how the script works.

If you want to import to a specific group you have two options:

Option 1 - Smart Rule

Create a Smart Rule that moves the mails from the global inbox to the desired database inbox (or any other group).

Option 2 - Indexed folder

  • Create an indexed group (search DEVONthink’s help for “indexing” and “indexed”).
  • In Finder: Copy the path of the indexed group’s folder (use contextual menu while pressing ⌥)
  • In the script: Set variable thePath to the copied path, e.g.:

set thePath to "/Users/Username/Desktop/My indexed folder"

This option doesn’t work with a database’s inbox as you can’t index an inbox.

I didn’t test this option but it should work.

@pete31 maybe I’m missing something, but the script doesn’t work for me. I have a Global Inbox /Inbox folder, how should I activate that ? Using shift + cmd + G in Thunderbird didn’t anything.

Did you use Thunderbird menu File > Save As > File before you tried that shortcut?

What happens when you run it? The script should display error messages if something goes wrong. Please post the exact text of the error message (or a capture).

Saving as file in the “Inbox” folder (I’m using the DT addon that create the inbox folder in the filesystem) showed the message correctly in the DT inbox, so nevermind I’m fine like this. Thanks