Import problem when scanning to an indexed folder


I’ve been using the ScanSnap iX1500 for a long time and scanning into an indexed folder (for a reason). Every last scan doesn‘t appear in Devonthink since a few days. As soon as you scan a new document, the previously scanned document appears. The error does not occur when I move a file by hand to the indexed folder (in the Finder).

(Catalina/DT/ScanSnap Home, all newest version)

Any ideas?

Thanks for help in advance!

Did you update the OS, DEVONthink or ScanSnap Home lately? Does the scan also disappear if DEVONthink isn’t running?

Thanks for your answer!

I haven’t made any updates! The problem suddenly appeared!

To make it clear: After the scan, the PDF file is in the indexed folder in the Finder. However, it only appears in Devonthink when I make the next scan (which itself remains only in the Finder). However, if I drag the file in the Finder out of the folder and drag it back in again, it immediately appears in Devonthink.

The file with the red arrow doesn’t appear in DT until next scan!

Does File > Update Indexed Items… add the item to the indexed folder?

Very rarely yes! Mostly not!

And nothing’s logged to Windows > Log?


And does the file appear after closing the window and opening a new one? Or restarting DEVONthink and choosing File > Update Indexed Items… for the indexed group once again?

Tried it with closing windows and “File > Update indexed items” and it works! Do you have a hint, why the behaviour is like that?

This might be a bug. Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!

In addition, is it already sufficient to select a different item in the sidebar and then the indexed group again?


Unfortunately not!

I have now done the following:

  1. All caches deleted with CCleaner Pro.

  2. Restart in recovery mode and check the hard disk with the disk utility

  3. System settings > Security > Full Disc Access reconfigured

The result is that the file appears at least through the menu command “File> Update indexed items” (until now).

Is the indexed folder located on the startup volume?


Does it work if you use a different indexed folder for your scans? Or after switching to icon/columns view? Unfortunately we couldn’t reproduce this so far and there was nothing in the logs.


BTW: I just send a screencast to support team (Jim Neuman)…

I think I’m having a similar problem. DT 3.03 Mac OS 10.15.2. I had given up on DT some years ago but thought I would retry it in v3 for a particular task I have. First I indexed a folder of images (all screenshots). About 300 of them. Then I exported more screenshots to that folder from Snap N Drag Pro. I couldn’t get them to show up by selecting that folder and using File -> Update Indexed Items. Using File -> Index Files and Folders did index them, but also included a folder of the original 300. OK, that was a bad idea. I’ve exported another 200 files from Snap N Drag Pro into that folder and tried to update the index, but it won’t update. My intended use would involve this folder being updated pretty often. As it is going now, this is not going to work out with DT…

Is anything logged to Windows > Log? Is the path of the mounted volume always the same or might change?