Import Problem

I’ve a problem with DT Pro public beta, when I import a document (picture, word, pdf, whatever) via drag’n’drop to the dock icon I can’t see the document in the new three-pane view or any other view except the list view.

I’ve tried other methods to import to - always the same result.

When I switch to the list view I can see the document in the “root”.

Ist there any solution/workaround?

Is it possible to select a predefined group (e.g. a “Imported” group) which is used per default for all imports?


I usually import files via the DT Pro Files > Import > Files and Folders route. I’ve created a special group for receiving imports. Here’s how: Create a new group. Name it “Imports” if you wish. Now go to DT Pro Preferences and click on Imports. At the bottom of that panel you will see a scrollable button that will allow you to choose a destination group, e.g., Imports. That’s one way.

If you are a dragger and dropper by preference, here’s something you will probably love:

[1] Open DT Pro Preferences. Make sure that “Hide ‘Groups’ panel when inactive” is not checked.

[2] Select Tools > Show Groups. A new panel will be displayed. It displays all the groups in your database. Click on (or drag a file onto) a group. If there are subgroups, they will now be visible – and if they in turn contain subgroups, clicking or dragging onto them will display those subgroups, and so on.

[3] Size and move this panel for your convenience. Mine is on the right side of the screen, just wide enough to display the group names, and taking up the full vertical dimension of the screen. Now, grab the top of the panel and move it down to where the top is just showing at the bottom of the screen, and just above the area that triggers display of the Dock (I’ve got the Dock set to hide). It’s important the the green button be visible; when clicked, the almost hidden panel will jump back up to where you had last placed it (click the green button again, and the panel will jump back to screen bottom). Another approach would be to minimize the panel (click on the yellow button) instead of placing it near the screen bottom, and display it when needed by clicking on its icon in the Dock. Use the approach you prefer.

Here are some uses:

In the Finder, select one or more files that you wish to import. Now bring the Groups panel into view and drag the files to your chosen destination for them. Easy.

In any application, select text and/or images, pop up the Groups panel, and drag the selection to your chosen destination. This works with applications such as MS Word, which isn’t compatible with Services, or just about any application you may use. Neat!

How’s that? It’s much more versatile than dragging items onto the DT Pro Dock icon.

1st - thanks for your helpfull comments

It looks like this is working only for New Memos (in the Preferences pane the scrollbutton is also labeled “new memos” (for me in german, “Neue Memos”). If I use import via the file menu the file is still in the main group. My mistake?

THANKS - very nice workflow, I’ll experiment a little bit with this, looks perfect for my needs.

Thanks again for your help!

PS: I findout that I can see the files in the Three-Pane-View when I disable any group and click outside all groups - then the files are in the list - ok this is logical, if the left side does only display the groups and the file is not in a group …

Bill…great tip and i’ll experiment with it.

one ‘feature request’ would be to allow this to function like a tab from DragThing, where if i mouse over the Groups title bar it automatically displays the Groups list, then automatically minimizes again when the mouse is removed from it. would save a click maximizing it and then another minimizing it. i could just drag something over to it, it auto maxes, i drop it where i want and i’m done.

but i still think there’s a bug with the 3 pane view. as frank said, the files are there, just invisible. doesn’t seem like a sound design concept to me.

Bill, I love that floating groups panel. Thank you!

Maybe I’m misunderstanding you and Frank, but I thought the same thing at first. Then I found that the trick is to click on the left pane below all the groups. That brings up the top level and the newly imported files will show up in the top pane.

right. what that means is you are essentially clicking on something that is ‘invisible’ and now it displays. clicking under the last group is essentially clicking on ‘everything else not in a group’. that’s fine, but you shouldn’t have to click on white space to find it. that’s bad design.