Importing from Mac Mail - Some Do, Some Don’t

Are the emails which work and don’t work located in the same mailbox/account or in different ones?

Yep, same mailbox. And I wondered if it was date sensitive (maybe newer ones cross and older ones don’t), but I can go back in time several years and some will come and others won’t.

Is anything logged to Windows > Log?

Screenshot 2023-01-27 at 9.44.40 AM

Is it possible that at least sometimes the email was already imported to the same database?

I don’t think so. When a duplicate happens the log tells me “Skipped already imported email” and when I do a keyword search inside DT the email doesn’t pop up.

The date shouldn’t matter but maybe the sender and which email client or text encoding was used?

Can you drop to the Finder then import that .eml file?

I am experiencing the same issue trying to drag in an email from Apple Mail. - it is a brand spankin’ new email and when I drag it from Mail to DT I receive the fail message in the log.

Dragging the same email to the desktop and then to DT works as expected.

Any suggestions to fix the drag from Mail to DT?

Have you tried rebuilding the mailbox in Apple Mail first?

Yes, I have rebuilt the mailbox but the condition remains the same.
Tried dragging in various emails and each had the same result.

And what OS and version of DEVONthink are you running?

13.2.1 and 3.9 but I have been experiencing this behavior for a number of months

It appears you’ve stopped trying to help with this issue. I have a similar problem - when I try to drag and drop an email to DT3 from Apple Mail - I get an interminable spinning beach ball and after 20 or 30 minutes I am forced to quit Mail and DT3. Very frustrating.

Please ensure that DEVONthink 3 is allowed to automate Mail.

After the latest update to MacOS. Ventura (beta) I can no longer enable or use the Apple Mail Plug-in.

Note: this was working on the prior MacOS ventura. I assume this will be handled in a future DT3 update but posting here in case anyone has found a workaround.

To confirm you are expecting the plug-in to work with beta Apple software?

Have you tried the solutions given in this forum on other threads? Do a search to find one of many.

This is indeed an issue with the beta and is being looked into. However, unless you’re explicitly testing the OS, don’t run a beta operating system on a machine you need to be running normally.

Thanks @rmschne and @BLUEFROG the response.

I know the risks are all mine when running on MacOS beta software.

I did a search here in the Community for Ventura, DT3, and Mac Mail and ended on this thread.

I look forward to the DT3 update.

Iin the meantime dragging and dropping from Mail to DT3 works for just fine. My primary use case for the Mail Plug is to move individual emails to DT3 from the message menu.

1 Like

I have experienced this same behavior. I go around it by exporting to a third location (I.e. desktop) and then importing to DevonThink. I can’t seem to find a pattern or cause.

1 Like