Importing indexed files

Hi all,

A small procent of my database files (still a considerable amount) is indexed while the rest of my files are imported. I want to tidy up my database so that if I make a back-up I only have to back-up the database-file.

So, this is my question: is it possible to automatically import all the indexed files in my database and delete the original files after I’ve imported them? Or do I have to go through my database and import / delete the files manually?

(I searched to forum but couldn’t find any info on this. If this question was already answered, thanks for directing me to the relevant post(s).)

Thank you

Solved: see last post(s).

Not completely automatic, but fairly painless. First create a smart group where ‘Instance is Indexed’. Then select all the indexed documents in the smart group, right-click, and select ‘Move Into Database’.

Excellent. Thank you very much!

I tried this but it didn’t work: I select all the files but I cannot click on “move into database” (it is gray). Any ideas?

Also, using this scenario, would I still need to manually put the now imported items in the folder they were before? Or will they be put in the right place? And will it delete the indexed file (either in the database or in the original folder OR both). This would probably become clear when I test run it but since it didn’t work…


The only think I can think of is perhaps some of the files are not indexed?

When (if) it does work, the files will be moved from the filesystem into the same folders they were in before.

I tested a few things (it’s not because their are some files that aren’t indexed, not because there are groups or duplicated / replicated files in the smart group).

It seems that the “move into database” function just doesn’t work in ‘smart groups’. I cannot even move an individual instance into the database from the smart group (while I can move the same instance in the database from the group where it is located).

It’s seems like I will have to go through the database group by group. Or would there be another short cut?

You’re right, it’s not enabled in global smart groups of the sidebar (the next release will fix this) but it’s available in smart groups inside databases.

Excellent, that worked like a charm. Thank you.


Make a smart group INSIDE YOUR DATABASE (NOT in the global smart groups in the side bar) with “instance is indexed” as a rule . Select all, right-click and “Move into database”.