Importing mail scripts, where to find them?

I installed DT Pro and would like to import emails from If I’m reading the information correctly, DTP installs the scripts automatically on installation, but I cant find the script that imports from (there is no script called “Add message(s) to DEVONthink” on the scripts menu). I even did a global search for “Add” or “DEVONthink” on my HDs with Easyfind, and did not find it. Any ideas where I can get the scripts?




While viewing Mail and with one or more messages selected, go to the menu bar and select Scripts (stylized S) > Mail Scripts > Add Message(s) to DEVONthink.

That should do it.

Thanks for your answer Bill.

The problem is that I cannot find the script you mention. For some reason, the devonthink scripts did not get installed (I think). After installing DTP, I went to the helpmenu > Install add-ons, made sure that all items were checked (Applications scripts, etc) and clicked Install. Then I checked in and there is a mail scripts submenu in the Scripts menu, but no script to add mail to Devonthink (actually, no DTP-installed scripts at all). The Scripts menu in DTP is fine, though.

Now, if the scripts for were not installed, how can I install them manually? Are they downloadable from the DTP site?

Thanks again,


I’m having exactly the same problem. Am running 10.4.3.

Look forward to a reply.

You have to activate the script menu extra of Mac OS X and then the scripts should appear (assuming they were installed) whenever Mail is the active application.

If that shouldn’t be the case, please check if there any scripts at all in the folder ~/Library/Scripts/Applications/Mail installed.

Similar problem here with the script for Powermail “Add message(s) to DEVONthink.scpt”.
I followed the instruction in the Devonthink Pro Turorial and the script can now be found in ~/Library/Scripts/Applications/Powermail. But it does not appear in the Powermail sript menu. How can I get it there?

OS 10.4.2 | DT Pro 1.0.2 | Powermail 5.2.1

Same issue - the installation of the scripts is optimized for the script menu extra of Mac OS X so that all scripts are accessible via one menu no matter which application is currently running.

To active the menu extra, use /Applications/AppleScript/AppleScript (Tiger) or /Applications/AppleScript/Install Script (Panther).

Yes, now it works. I did not realize that there is a systemwide script menu to activate. Thank you.

Hi folks,

Despite my best efforts (reading all the posts I could find, re-installing, browsing throught the depths of my machine…) I cannot get mail import to DT to work (no scripts found). I see that others have had similar difficulties but they all seem to have found solutions – none of which have worked for me.

I have installed a trial copy of DT Pro and have begun exploring it. One of the key things that initially interested me in this app was the ability to combine emails, pics, docs to orgainze projects in combination with CircusPonies Notebook (I read an interesting post by Bill DeVille on the CircusPonies Forum). I have been trying without success to get the import of mail into Devonthink from the apple mail program to work. I am running Tiger 10.4.3 and DEVONthink Pro 1.0.2. I went through the install successfully (or so I thought). Then I redid the install as mentioned in a post by Bill De-Ville – by creating a folder for DT Pro in my applications folder and then launching from there – I noted messages indicating that scripts and workflows were being installed).

I have the system-wide applescript menu enabled and use it regularly. There is is DT Pro entry in the script list and a number of scripts. There is even a Mail submenu which has a single script in it “Mail Rule Action Import”, but no Add Messages to Devonthink…

There is a separate script menu that appears when DT Pro is the active app, but I do not have a similar separate script menu which appears for Apple Mail.

I have checked the Library/Scripts/Applications/ folder and I do not have an entry for Mail or DT Pro (nor do I have permissions to create a subfolder). I do however have an entry: Library/Scripts/DEVONthink Pro which has a Mail subdirectory with the “Mail Rule Action Import” item in it.

I also have a directory Library/Application Support/DEVONthink Pro/ with folders corresponding to the scripts available from the DT Pro menu.

So, from what I can tell from reading the posts, the “Add messages to devon…” script should appear in a separate “mail only” menu-bar script menu which is present only when mail is active (like the separate DT Pro script menu) and does not appear in the system-wide script menu (although I do get other DT Pro scripts there).

I would greatly appreaciate any further guidance on this issue. I most likely am missing someting basic as I am relatively new to Macs having recently switched from a lifetime of Windows work (My first computer was an apple IIe in 1983 but I don’t know if that counts).

Thank you,

Mark :open_mouth:


As far as Im concerned, the Apple //e counts. I got a ][+ in early 1980. :slight_smile:

The scripts for Mail should be at this location: /YourUserName/Library/Scripts/Applications/Mail/ and are named “Add mailbox(es) to DEVONthink.scpt” and "Add message(s) to DEVONthink.scpt.

When Mail is your frontmost application, click on the system-wide Scripts menu icon in the menu bar. You should see that the Mail Scripts folder has automatically opened and shows those two scripts as available to you.

Thanks for the quick response and welcome Bill,

When I navigate as you directed to


There is only one subdirectory – Virtual PC (so that I can run the few specialized apps that are not yet on OSX)

I have no Mail subdirectory.

If I back up one directory to the …/Scripts directory, I have the following
/Address Book Scripts
/DEVONthink Pro
/Mail Scripts

My machine is a Powerbook G4 17 which had a clean install of Tiger (not an upgrade). All my apps and other scripts seem to work well.
I tried to create a folder under the Applications directory – no go.

I also ran the install add ons again (from DT Pro).

So some how I am missing this folder. What do you think I need to do?





As I probably didn’t delete older scripts, I’ve probably got multiple copies of some of my scripts in different locations, which makes it confusing in deciding where to tell you to look. But that’s not really the problem.

With the Mail application fromtmost, Mail Scripts > “Add message(s) to Devonthink” should appear in the System-wide Scripts menu if the Install add-ons routine had been run

If you can’t see it there, perhaps the routine to install the scripts failed because of a permissions problem, i.e., the script could not be written because of a permissions error for a folder.

Go to Applications > Utilities > Disk Utility and run permissions repair on your boot volume. Then in DT Pro run Help > Install add-ons again. Go back to Mail and look for the script under the system-wide Scripts menu.


Thanks for you help.

I repaired my permissions – there were not any problems. I tried the install add-ons again – no go. I uninstalled DT Pro and re-installed – no go. I don’t think that the forum can offer any more help for this.

My next plan is to send a direct email to tech support and ask that a copy of the applescript files be sent to me – I can install them directly.

As a side note, I examined all the folders in the download and can not find the sought after mail scripts. The “about these scripts” pdf file mentions three subfolders: Additions, Script Menu, and Examples, but I do not find such an organizationi – I find workflows, droplets etc…

Hopefully I can resolve this.

Once again thank you for your help.



just open the “DEVONthink Pro” application package using the contextual menu command “Show Package Contents”. Then navigate to the subfolder Contents/Resources/Script Menu.

This subfolder includes all scripts which should be installed in the folder ~/Library/Scripts of your account.

For example, Contents/Resources/Script Menu/Applications should be copied to ~/Library/Scripts/Applications.

Thank you Bill and Christian,

Once I bored down into the package and found the script folders I tried to copy them to my /scripts/applications/ folder. I found that the folder was owned by “System” but that I only had read-only privilege on the folder so I could not add the folders (and neither would it seem could DT Pro). So I modified ownership, then priv. to read/write, and tried the “install add-ons” option – Voila!

All now works as it should.

So, If other readers make it this far down this thread without a solution – look into the specific permisions on the scripts subfolders (note these permissions do not appear to be reported one way or the other by disk utility – perhaps it has been suggested, because they are user folders).


Thanks for that Mark. I have been experiencing exactly the same problem, but it is now resolved after I changed the permissions on my /scripts/applications/ folder and re-ran the ‘install ad-ons’.

What a relief


I had the same problem and discovered that there are TWO folders called Scripts/Applications on my iBook. One is located in the Home folder and the other is simply on the hard drive, with no enclosing folder. It is this latter that the system uses. The new scripts work when moved there, not when they live in the folder of the same name in the Home folder.

My question is: Does it matter in any way that my scripts, contrary to the DT manual, are not in the Home folder?