Importing OpenMeta Tags

Is import of OpenMeta tags working correctly in PB8?

File > Import > Files and Folders… does not seem to display the OpenMeta tags in DTPO. But, if one of these files is renamed and exported, the OpenMeta tag is still there.

It gets weird. If a tag is added in DTPO, then the new DTPO tag shows as an OpenMeta tag. but the original imported tag is now gone.

Not an answer but I hope a related question. Is there a way to synchronise openmeta tags with devonthink tags without importing or exporting? I would like to be able to tag PDFs outside of DTP, but have devonthink ‘see’ the tags in an indexed (not imported) folder?
Could this be scripted?

My pretty cursory tests indicate that DTPO imports OpenMeta tags on an index. Have you tried it and found it not to work?

Best, Charles

As best as I can tell, it works on the first import … but does not work when I synchronise the folder to update changes and new tags that have been added. Does this make sense?

Interesting, I haven’t tried that, but will in the course of the evening.

What are you tagging with outside of DTPO? Sounds like it isn’t changing the modification date of the file, of whatever DTPO must look at to decide a file needs re-indexing.

Doesn’t the DTPO log track what’s been re-indexed on a synchronize? Are the files to which you added tags showing up there? (In other words, is DTPO simply not re-indexing the file, or is it re-indexing it, but missing the updated tags?)

Best, Charles

I’m using Tagger: and from what I can tell, updating or adding tags doesn’t change the modification date of the tagged file. So DTPO has no way of knowing it should re-index (synchronize) the file. (Updated files are listed in the log as part of synchronization.)

This makes sense, because you haven’t modified the file, you’ve just changed its xattributes, which is a reincarnation of the old MacIntosh “resource fork.” It may go even deeper to the OS support for reading and writing xattrs.

“Touching” the file via the command line will do the trick, but I’m looking at a simple way to tag in DTPO and have it update my indexed files.

HTH, Charles

Hi Charles
Thanks for the reply.
A two way system would be ideal so that tags applied in DTP and those applied outside via openmeta could be synchronised when the file/folder is re-indexed/synchronised.
Is this feasible - something that is likely to happen?

Well, the scriptability of DTPO really removes most of the limitations folks argue about on this forum. I just code what I need, and usually find that other applications, not DTPO, are constructing limitations on what I can do with my data.

So certainly you could create such a thing, but programming might not be your cup of tea…

Best, Charles

Hi Charles
Not so much a cup of tea question, as whether or not I have the teapot skills to make it happen. Will have a bash when I have a bit of time … but if anyone else out there feels like taking on the challenge that would be almost inevitably be better.
Will post here is I get anywhere

What exatly do you mean “on an index”?

And, I mostly use Tagit for OpenMeta tagging and don’t see resorting to a script for simple file imports.

DTPO Menu: File->Index…

“on an index” == “when indexed” :slight_smile:

I’m using Yep 2 for PDFs. I tried Importing a bunch of PDFs that I’d tagged in Yep 2, and all the tags came in beautifully!

I only wish I could use the Index feature in DT. It crashes pretty much all the time on me.

If I had a way to use the Index feature without crashes, then I would Index all my PDFs (rather than Import them) and probably switch over from Yep to DEVONThink.

@cturner and @sjk, thanks for the clarifications. I thought maybe what was meant was waiting for Spotlight to index the files or something along those lines.

I do want to Import and not File > Index… But either way, Import or Index, my OpenMeta tags do not appear in PB8. At least tags assigned by Tagit.

@Sandy Santra, thanks for the report. I tried a Yep2 demo copy and all tags on many different types of documents imported as expected into DTPO. Both Yep2 and Tagit are produced by Ironic Software and supposed to be supporting OpenMeta. Tagit tags aren’t read by Yep2 either, so I don’t know what is going on, but have contacted Ironic Software support for some guidance.


I just downloaded a copy of Tagit, tagged some files with it and they were indexed by DTPO, tags and all, without trouble.

HTH, Charles

@cturner, thanks again. Ironic Software also said Tagit should work as expected. So, I simply deleted the application and com.ironic.tagit.plist files and downloaded a fresh copy of Tagit 1.2.1.

And now tags do. The only differences from before are a newer Tagit and putting it in /Applications and not in a sub-directory within /Applications.

Thanks to everyone for their time. The fix should have been obvious except for my dummie troubleshooting off on an exotic tangent.