Inconsistent context menu items in safari

Here is a minute bug report.

On macOS Monterey, the context menu items of DT in Safari became inconsistent in their wording. Some of them are prefixed by “DEVONthink Pro:”, some are not. It baffled me at the first sight finding out “Take Rich Note” was not available anymore, which turned out just listed away at the bottom of the list.

Thanks for the report!

Is this on 12.0.1 ?


What app are you making your text selection in?

In Safari. For what it’s worth, this page

I’m updating my Monterey machine right now but I’ll try it out once it’s done. Thanks!

1 Like

Does a restart of the system fix this? What’s your system language?

Just tried restarting safari and restarting system, the issue persists. My system language is English, with Traditional Chinese in secondary place.

Does it work after downloading the app again from out website, replacing the installed one and rebooting the computer? Or are there still older versions of DEVONthink/DEVONnote installed? The shown name isn’t used by DEVONthink 3.

Just a follow-up… I am not seeing the same issue you reported here on Monterey.

I am not seeing Chinese - Traditional (Taiwan) available in the Keyboard Preferences. Which option is this?

I’ll try that tomorrow sometime, and get back to you once I’ve done that.

Some background: I re-formatted disk and re-installed macOS Monterey from scratch. And I didn’t use a Time Machine backup for data recovery. So there’s really no older versions still around. But I also find there’re some other minor bizarre glitches going on somewhat arbitrarily on this install of macOS which baffles me very much. So if you guys can’t reproduce this behavior I’m inclined that this might just be a very rare issue that happens to an unfortunate macOS install…

However bizarre the situation is, I can confirm clicking the Take Formatted Note or Take Rich Note menu item does create corresponding HTML or RTF document as expected in DTP 3.

See my response to cgrunenberg. I’m not sure if this is just an issue of this macOS install.

It’s in Language & Regions, not a Keyboard preference.

If it turned out just an issue of this install of macOS, I’d be sorry for wasting your guys time.

No worries! It’s why we’re here. Always something to learn.

1 Like

A follow-up:

Just upgraded macOS to 12.1, and the problem has been resolved automatically. Indeed a bug of macOS 12.0.1.


Thanks for the follow on this. Much appreciated :slight_smile: