Index'd file not being searched

I have a plain text file containing the words “poet hath written”, which I indexed into my database by selecting “File | Index…”. It was pulled in with a few hundred other text files.

However, no search that I try will find this file, unless it’s a single word such (like, for “poet”). A phrase search does not find it at all.

I had been finding this file with the search before, so I figured the difference must be that I indexed it instead of importing it. Sure enough, if I import the file (so that now I have an indexed file, and an imported file), it finds the query within the imported file.

I tried rebuilding the database, but no change, it still only finds the string in the imported file.

Any ideas?


You have correctly identified a difference between indexed and imported files. Currently, Phrase searches don’t work with Index-imported files.

Of course, your phrase “poet hath written” would find the Index-imported documents if you used an All Words search. But you may get "extra’ documents in the search results and it’s not as easy to locate that specific string in the Index-imported documents.

If you are still not finding that document using an All Words search, check the search options that you are using. Select Tools > Search, press the Options button and carefully examine the selected options. Is the search set for a specific group instead of a database-wide search? Are you perhaps filtering by State or Label? In other words, set your options so that every document in the database will be examined.