Indexed files not fully syncing

Have a DB with indexed videos that are stored on a NAS:

Issue - when moving the files into the DB on Mac A, they move in from the NAS as expected. When Mac B syncs, the videos remain indexed on Mac B and put the videos back to the NAS. Result is Mac A with videos in the DB and Mac B with videos indexed to new copies on the NAS.

  • Subsequent flagging and labeling on Mac B sync as expected but file remains indexed on B and in DB on A.

  • Moving the video item on Mac B to a different group results (after syncing) in the moving the file to the new location on Mac A but t file remains indexed on B and in DB on A.

  • Moving the file on Mac A to a different group results (after syncing) with both th file in the DB on both Macs and the file no longer on the NAS

There seems to be not effect on the iOS devices that are synced to the DB.

Is this how the sync is supposed to handle index file syncing across macs?

I’m confused. You’re importing the same files on Mac A but indexing on Mac B ?

Which version of DEVONthink do you use? I’ve just tested this using both Bonjour and sync stores with DEVONthink 2.9.4 and after moving a file into a database on Mac A, the file is also moved into the database on Mac B (and vice versa after moving it to the external folder).

I am confused about this, too.
The orig post explained what DTPO is doing when syncing a DB with indexed video files between 2 macs. I assume it is syncing differently than intended/ designed?

I want the sync to make the DB on both Macs the same but sync is not doing that with the files that were moved into the DB by using the Move into DB command. Perhaps the sequence of steps and states below will better explain.

Initials state:
DB is synced and the same on both Macs with video files indexed on a NAS accessible by both Macs.

My action on Mac A: Select an indexed video file in DTPO and use the “Move into Database” command. DTPo moves the file from the NAS into the DB resulting in no video file on the NAS (as expected).

Macs Sync

Resultant State:
Mac A: DB is the same as expected with Video file inside the DB.
Mac B: DB still shows the video file as indexed to the file on the NAS.
During the sync, DTPO creates a new copy of the video file on the NAS and does not change the state of the DB on Mac B to include the video file within the DB.

Subsequent syncs do not correct but will sync flags or labels added to the video file as expected from either mac.

If the file is moved to a different location within the DB on Mac B and and DTPO syncs, Mac A will reflect the new location but the sync does not correct the index vs “in DB” disparity between the 2 Macs.

If the file is moved to a different location on Mac A and DTPO syncs, the sync corrects the index vs in DB issue and has the file in the new location in the DB on both Macs

I assume this is a bug.

Using 2.9.4 on both Macs, Webdav syncstore on Synology NAS running current DSM

Just tested using different file types in the Global inbox – resulted in same behavior except that moving the file to a different group with the Global inbox did not correct the other Mac DB upon sync.

Note: The indexed files are NOT within a DTPO group that is indexed.

So on my end , unless I have really messed it up - the behavior is repeatable, consistent and independent of database or global inbox.

Wonder if it is an issue with syncing webdav to Synology? I ask because the DTTG2 syncing issues I experienced prior to the current rev were significant when syncing webdav on Synology and minimal when syncing via DropBox.

Also, I notice that after syncing an indexed file on the second mac for the first time, the Synology shows that the file has been deleted and replaced with a new copy (a copy of file shows up in the recycle folder as if it were deleted on the Synology, but the file is still in the proper folder on the Synology). I noticed this because the Synology recycle folder got very large.

Just tried this but it’s working as expected. Do both Macs use the same NAS files/folders? The synchronization expects that each Mac uses both its own copy of the database and its own indexed files/folders.

The only exception are cloud folders (like ~/Dropbox), in that case it’s up to the cloud app to synchronize the files/folders.

Both macs use the same NAS share which is mounted on each mac. When the sync first occurs after indexing a file on one mac (file in the mounted NAS share in a folder) all syncs as expected as the DBs on each mac point to the proper file on the NAS.

Also just tried the with syncing the global inbox via Dropbox and have the same problematic behavior.

“The synchronization expects that each Mac uses both its own copy of the database and its own indexed files/folders.” What do you mean by “and its own indexed files/folder”?

The cloud service used by the synchronization doesn’t matter, the location of the indexed files/folders matters. This location can’t be identical on both Macs.

So that means that sync will not work as I expect when using DTP to Move Files into and out of the DB if DBs on both macs have indexed files hat point to a NAS share/file accessed by both Macs??
But it will work as I expect if the indexed files point to a local folder that is synced by a cloud service??

So from my experience - the sync will work as I expect with both MAC DBs indexed to the same NAS share as long as I do not use the DTP function to move the files in to and out of the DB- but don’t think I have tried or noticed if the sync still works as I expect if the file in just modified on one mac and synced.

Bottom line - DTP sync will work for indexes of local files that are cloud synced (dropbox, Box, BTSync, private cloud) but not files that are indexed to the same file accessed on a network… Do I have that right?

Almost. Local indexed files/folders are synchronized, a cloud folder isn’t necessary. But indexed files/folders located on a shared server/volume aren’t supported as each copy of DEVONthink tries to update the files/folders on its own.

Ok - I understand an appreciate your help in getting me there.

I am looking for a way to use DTPO and its sync along with using the NAS as my main file repository. As best I understand - the DB should not be on the NAS and synced /indexed files should not be on the NAS. Any advice other than just having DTPO manage all the files and not use the NAS for those files?

Full disclosure - I haven’t yet viewed the sync video that you folks put up in the last couple of days, but it seem a bit difficult to get a grasp on how the syncing working. Not the technical parts, but the parts that enable me to determine my approach to using it.

Also - FYI I just tested if a synced file that is indexed to a NAS share (the way you just helped me understand is not supported) and see what happens when modifying the file contents. It seems fine on both macs after changing the file, in both directions, but since syncing indexed files that way is not supported, the fact that the files seems to sync as expected is not to be relied upon … and just a potential undocumented but perhaps unreliable feature to be used at one’s on risk. :slight_smile:

One possibility is to import the files/folders instead of indexing them, another one is to store them in local indexed folders (e.g. ~/Documents or ~/Dropbox).

Not all operations cause troubles in such a setup but at least moving items into the database or to the external folder do.

Got it – Thanks for all the clear and direct help. Looking forward to DTPO 3