Indexing new files via Folderaction/Automator workflow

Hi folks!

I attached an Automator workflow to a folder that should index every new file copied into that folder in DTPro. The workflow looks like this:

(Ooops, somehow the first action didn’t translate into English. It is “Get Selected Finder Object”)

However, when I start the workflow, I get this error message:

This happens regardless of the file type I try to index. I tried RTF and PDF, both file types DTPro definitely understands. The error message also occurs, when I try to import (not index) the files via the workflow. It does NOT occur, however, when I import them manually via Drag&Drop.

What’s going on here? Can anybody help?

Thanks in advance,


reordering the actions should fix the issue:

  1. Open Database
  2. Set Current Group
  3. Get Selected Finder Items
  4. Add Items To Current Group

Note: Workflows are like pipelines - every action has its own input and output and therefore the Finder selection will be lost if it’s not executed right before “Add Items To Current Group”.


Unfortunately it doesn’t work. I changed the workflow according to your suggestions:

But I still get this error:

Kind regards,

Maybe it’s a bug - v1.1 will fix several Automator issues and therefore this workflow will work (just checked this). This version will be available soon.

I am looking forward to it.

Thanks for your help.

Kind regards,

This was a bug and is fixed in the upcoming 1.1. :wink: