Initialization Error - Database is already in use !

Hi All

I have recently purchased the personal edition of DEVONthink as a personal storage database for all my documents/pdf’s/web archives etc. I have a G5 iMac and Macbook. I have been successfully building database on iMac then copying the
/Library/Application Support/Devonthink folder to shared external firewire storage and copying onto macbook for when out and about. This has worked fine for last couple of weeks, but today i must have done something wrong/different.

Error message as above “database is already in use!” following this i have followed these steps.

Checked these forums and FAQ’s
Deleted all instances of Devonthink folder from /Library/Application Support and recopied over
Deleted all instances of Devonthink folder and recreated a new folder with empty database (works fine) then copied over backup and files seperately and tried to restore ( but only restored new empty database)

I can of course reimport all the files ( 400megs) which wont take long but have just finished sorting and grouping…

Is there any locked file status i am missing?
Am i following correct idea for sharing database?

Any help you guys can give me would be much appreciated before i import and regroup etc



Hi, Chris:

Copying a DT PE database and moving it to the Applications Support folder inside your user Library will work.

But DT PE should always be closed before making the copy. Making a Finder copy of the database while it is open may leave some data in RAM, and can create errors that may grow over time.

If there had been a file with its name ending in ‘lock’ it could be deleted – but that doesn’t seem to be the case.

Here’s how to recover your DT PE database as of its state when it was last backed up:

[1] In the Finder, create a new folder and name it DEVONthink.

[2] If there is a folder named Files inside your DT database, copy it (Option-drag) to the new folder.

[3] Open the folder named ‘Backup’ inside your DT database. Select all the contents and copy them to the new DEVONthink folder.

Result: Your new DEVONthink folder now contains ten numbered files and the Files folder. It represents the state of your database as of the time of its most recent backup. Place it in the appropriate location and launch DEVONthink PE. It should open. Inspect it and then run Tools > Verify & Repair. If there are no errors, run Tools > Backup & Optimize. (If this was a ‘bad’ database repeat steps 1-3 above, choosing the next most recent backup Folder, Backup0, in step 3.)


Thanks for the prompt and well explained reply. I followed instructions ( after first fixing permissions in OS X) but to no avail. Nevertheless, I had a previous full copy of the DEVONthink folder on my memory stick, copied that over ( just a few documents out of date) and its just fine again.

I take note that it is most important to check that the application is NOT running when copying over the full folder but once it was corrupted/locked there seems little I could do. The application opens but all options apart from formatting and preferences are greyed out.

Great product, vital tip tho… keep a couple of backups at different time/date stamps just in case…