invisible email attachments

I am running DevonThink Pro Office 2.8.3 on OS X 10.10.2.
I have imported emails from Apple Mail with the plug-in using import email in Devonthink.
The imported files are shown as eml.
The attachments which are part of the email are included but invisible. For instance, I have a ten word email that shows as nearly 100KB. It has a pdf attachment but there is no way of seeing it or even knowing it there except for the amount of data, which is obviously not text.
By futzing with ‘convert to rich text’ the attachment briefly appeared but then vanished again.

How I fix this?


Converting to rich text should definitely retain the attachments. However, there’s an easier solution by using the alternate view (see Preferences > Email or View > Text Alternative).

Many thanks for the tip. That did it.

I am just left wondering why showing attachments is not the default. Why would you only want to see half the content?

Also the description of the preference item “use alternative view” is completely opaque and meaningless. Why not use “Show Attachments” or “Decode mime sections” or something else descriptive?

I spent hours looking for the answers in the documentation but that really needs a big rewrite.

Anyway, thanks again for the prompt help.
Bill Northcott


Just to help myself in following conversation, are we talking about the “display PDF attachments of rich texts” under the editing tab of the preference window?

As an aside, on the last two posts I’ve made, I tried to attach screenshots via the upload option below. However, I get an error message stating “Could not upload attachment to…” Any suggestions?

No, it’s the option Preferences > Email > Message > Use alternate view. The default view is based on Quick Look and should be identical to the Quick Look panel of the Finder, its display & features might vary depending on the version of Mac OS X.

What’s the format of the screenshot?

I tried both png and jpg.

Did the filename contain any special characters?