iOS Shortcut fails to create new file. Group too large?

iOS 14.8
DTTG 3.2.4

I Keep all markdown notes in one group /Notes and all assets in /Notes/Assets

So there are hundreds of assets in that group.

I’m trying to use the iOS Shortcut “Create file…” in DTTG, and it seems to work fine on other groups, but not with the only one I want it to work on: /Notes/Assets

I’ve tried various ways of choosing the group as input, and tried running “Open group” first.

Is that to be expected with such a large group? Is there another way to setup the shortcut so it will work?

I have almost zero experience with DTTG and but pretty sure the number of items (or the total size) of a destination group is not the problem as this is not relevant to create a new item, I think.

I spent an hour trying variations. The shortcut fails precisely at that step (will do everything up to it, and won’t do anything following it.) If I chose any other group it all works as expected.

My backup plan is to save to a not-full group, and then have DT Desktop move the asset with a smart rule. Wouldn’t be so bad except my DTTG devices often wont sync automatically for days, even though I open DTTG and use it every day…

There is always the possibility of a bug in you shortcut.

Have you tried to setup a separate new shortcut for testing purposes and only add the Create Item action in the problematic markdown group?

You might also try closing Shortcuts and DTTG first by swiping up in iOS or even reboot your device, but do perform these steps one at a time.

1 Like

Did the shortcut work previously?

Please share a link to the shortcut or a screen capture so we can look at it.
I don’t have any other such reports of a problem.

Thanks for reply.

I’m not sure if it has ever worked. I never settled on any former “clip attachment to dttg” shortcut I’ve made, but can’t remember if it was ever because of this issue.

On iPad it fails with message “could not communicate with app”. iOS, no message.

the bare bones version in the screen shot reproduces the problem.

shortcuts can

  • open the group
  • save the same file to another group in the same directory

The group has 650 items totaling ~1GB

thinking the group itself was corrupt, I just made a new group with the same name and changed the name of the original. Then tested that the shortcut worked.

Transferred the 650 files from original to new group. Now shortcut doesn’t work.

Thanks for the follow-up. We’ll see if we can reproduce this behavior here.

If you create a file, you also need to set the file input in the ‘Show More’ section of the action if I’m not mistaken.

The ‘file’ option in the section above ‘Show More’ in part is a selector for the content of the ‘Show More’ section.