Is there an 'Auto Complete' feature?


I am writing a book and am thinking of using DEVONthink to organize my work.

Is that a good use for DEVONthink?

A feature I use in Pages at the moment is Auto Correct, after you set it up, you can type 'fs ’ and it is automatically changed to ‘Fred Smith’ this saves a huge amount of time and saves error.

Can DEVONthink do this? I can’t find it in my v1.9.9 demo.



I don’t think DT can do this but, if you are using OS X 10.6, the OS can do it (go to the “Language & Text” preference pane, then the “Text” tab–note that I do not use this so do not know how flexible it is).

Personally, I have been using a utility called Textexpander for some time (before OS X 10.6 came out), which lets me do that everywhere, independently of application. This is very useful to me.

Hi and thanks for your reply,

Thinking that it wouldn’t do it I went looking and found ‘Typinator’, sounds the same as Textexpander, universal access and will move the cursor to between HTML elements.

So far very pleased with it, will look at Textexpander before I purchase.



Yes, you can make use of text substitution provided by OS 10.6 in Plain Text and Rich Text documents created in DevonThink. Use the contextual menu from your document and you will see Substitutions -> Text Replacement. I use this to insert the greek alpha, beta, and gamma letters into my text. You have to toggle on Text Replacement whenever you create a new document, which I find annoying. I have not had the time to explore if this can be turned on automatically whenever creating a new doc, say via a scripted Template. And text substitution provided by Apple is not as full featured as the suggested third party options.

Here, the OS feature it seems to work without toggling. For instance, if I set it up to replace the two characters xa by \alpha, it just works, in all programs I’ve tried it, and without me toggling anything. That is, I type xa [space] and \alpha immediately replaces it.

I’d love to know what controls that. I cannot find a setting in either the System or DevonThink Preferences. I just tried creating a custom template by saving a new RTF document with Text Edit into the Tempates.noindex folder. According to the preferences I had set previously in Text Edit the new doc already had text substitution “on” (menu item checked). I quit and restarted DTPro. Then created a new doc using the Template file in DTPro, but the text substitution is now “off”.