Is this behaviour expected/correct? >> On Demand/Always

Hello all,

Would appreciate quick confirmation! (I’m pretty sure I knew this some time back - but recently had to set everything up again in DTTG - and things not working as expected).

1.) Top level: Settings>Sync>Locations>Edit Locations>Local Network>Edit>Download files=On Demand

2.) DB1 level>Info>Download files=Always
All appears to be there, even though - bizarrely - my iPP settings has DTTG as only taking up 5.2GB of space, when my DB1 should have over 30GB of data in it.

3.) DB2 level>Info>Download files=On Demand
I don’t want everything of this DB on my iPP, hence the above setting.

Here’s my question:

In one of the DB2s groups, I want everything pulled over.
So I have set it, after the initial sync, to DB2>Group>Info>Download files=Always.

Here’s the thing - no amount of syncing pulls down all the files inside that group. It still requires an individual “Download” on each file?

Is that the expected behaviour?

In other words, at top-level, I said “On Demand”.
First DB I synced, I went in, at DB top-level, and switched to “Always” - and this appeared to pull all down.
Second DB I synced, I left the DB top-level to “On Demand”, and then switched downloads to “Always” in one group, inside that DB.
However, this hasn’t pulled over the files for that particular group, which now requires an individual file-by-file download…

Is that my only option, or is it supposed to - once I set that particular group to “Always” - pull down all the files automatically on the next sync?

Kindly advise.

Ok. So I just finished setting up DB3 in the same manner as DB2, with all set to
“On Demand”, and then setting 1 group to “Always”.

As soon as I hit sync, it pulled all the files for that Group across, which is as I expected it to.
So the problem appears to be in that one Group, or with DB2 as a whole…

What are my options then to fix things? Delete DG2 in DTTG2, and try again?

Please start a Support Ticket. THanks.