Issue -1004 with WebDAV sync

Hi, I am working with several DEVONthink work stations, my Mac mini for home office, 2 MacBook for mobile use and iPad / iPhone for collecting articles of interest. A few days ago I have upgraded my Qnap device to a newer model with different firmware and did the new setup for WebDAV sync. Unfortunately it is not working, neither on my Mac nor on iPad.

Setup itself is ok, syncstore is being initialized and I am able to see the file in the NAS filesystem. Immediately after synchronization of the syncstore, sync is broken with error code -1004 NSURLErrorDomain with the message "Could not connect to the server.”

I already have reset up the Qnap nas, the syncstore on DEVONthink but no luck.

Do you have any hint for me for further analysis?

This is happing with DEVONthink only, Enpass is syncing as before without any issue.

Thanks for your support.

Any other QNAP users can respond but I would check with QNAP support. It would not be the first time a change in a QNAP device or firmware caused a WebDAV issue.

Can you connect to the NAS from the finder (Go to server…) with Webdav?

Thanks. I have created a support ticket with Qnap already.

Did not tried it in finder but I can connect in web browser and WebDAV client on iPad. So I believe finder should also work…?

You’re right, if it works in the browser it should work in the finder, too (Synology is a bit weird in this respect, though).

Doesn’t Finder use different protocols (AFP and SMB) than Browser (https and http)? Is the “should” valid? Just checking.

Good argument. Will try it later and come back.

Depends :stuck_out_tongue_winking_eye:
If you “go to server” with smb:// and afp:// URLs, it uses those protocols. If you use http(s)://, the finder uses Webdav.

For that to work with the current Synology, you have to turn off Caldav in their Webdav settings, though.

Hi, I have tried to connect via finder using https and its working perfectly.
Same behavior as described before with Devonthink.

On QNAP there is no caldav but there is a checkbox for HTTP compression and another for TLS protocol level. This is new but I tried every combination without any success.

Thanks for your ideas!

I’m usually proposing to check with finder (or traceroute :wink: to figure out if there’s an underlying network problem (like no DNS resolution or so). Apparently not so here, so let’s hope that QNAP fixes it.

Same problem here :exploding_head: DT3.6.1 gives me a 1004 Error while syncing. Its no problem to sync empty databases. Last week it worked without any problem :sob: I can connect to the QNAP via macOS Finder SMB and Cyberduck. Running QNAP QTS Opened a ticket. Hope for quick help :innocent::kissing_heart:

Welcome @robertomk
Did you update the QNAP in the past week?

Yes, at the weekend. I have no problems with other connections, protocols and apps! The only problem is DT. I attached the log from the macOS console to the ticket

Interesting! Any way to get the nas to the former firmware release manually? I would like to try because QNAP was not responding actually and I have to decide giving back the nas latest on Wednesday German time.

Same for me. Empty database no issue.

I don’t know if I can go to former firmware. I don’t see this as a solution! All other apps macos and ipad have no problems with the qnap. So should it really be the solution to downgrade? And whats with security fixes qnap made?

Please leave a feedback after downgrading. Thx

You are right but it would be worth a trial.
Will give feedback afterwards.
Please could you give me the last version before? I have upgraded from 4.3.3…

oh I missing a couple of updates. I think I upgraded from 4.3.6 but I cannot say for sure.

What “all other apps” ?

Last week it worked without any problem

And you answered you did update the QNAP in the past week. If you were running DEVONthink 3.6.1 last week and it was running, then how would that point to DEVONthink being at issue if it was working before the QNAP update?