Issue With Using Sync Stores on NAS Server Between Mac & iOS

Hi there
Use Devonthink Pro Office & Devonthink To Go and am trying to get syncing working across both using a QNAP NAS in the middle without success. Currently if I use a webdav sync store (QNAP is setup for this) I can create a new store using the Mac writing to the QNAP without issue except I do see an ‘Unimplemented 501’ error although it completes the sync.

When I go to the iOS device and input all the same details I get the same error but won’t complete the sync and never completes in the add location options of DevonThink To Go.

Same thing happens in reverse though, can create a new sync store using webdav on the iOS app and it completes without issue, however, try to then connect the Mac to the iOS created sync store and same issue, doesn’t complete sync. So not sure what is missing in the middle on this and why both can create new sync stores using webdav on the QNAP without problems BUT connecting to sync stores each other has connected on the webdav (with the purpose to sync of course) fails.

Anyone seen this issue, know what the unimplemented 501 means and how to resolve this ?


Please ensure that the URL contains the right port in case of HTTPS.

Was this ever resolved?

I am trying to set the same up and also get the cryptic “unimplemented (510)” error.
I syncs a few 100 docs, then I see the message. I see stuff arriving on the server, so the networking part is definitively correct. I have no idea if it synched everything. Sometimes it runs right through.
The iPad always gives this error straight away, doesn’t even save the WebDAV location.


On a QNAP NAS, you should only use port 443 for . Don’t use a non-standard port or you’ll get the 501 errors.

Thanks, that did indeed work!

However, two (constructive) criticisms:

  1. The error message is poor. Especially if it is a known issue, there’s no excuse for not providing a sensible response to the user.
  2. Why not support other ports? There are good reasons for using other ports.
    The QNAP default is 8081 because https is used for other purposes, and folks may not want their WebDAV server exposed to the world. I have very limited stuff on the standard https 443 port and VPN into my network for the rest. This is good, but now you force me to put my WebDAV ‘out there’. :neutral_face:


You can use another port but DT support for WebDav is non-existant. The party line is either a user posting “it works for me and always has” or the official response of “your WebDav is broken”.

Particularly on multiple QNAP servers, the issue seems to be related to the manifest file and the inability of either DT or DTG to maintain connectivity to the server across more than a very small number of documents, and the neglect of the error handling of either app to report meaningful errors associated with the failure.

I have heard rumors from those more passionate than I at finding a way to drag functionality out of the apps, that if you simply repeatedly check and uncheck the individual databases over and over again and ignore the error messages, which in any case are useless, the initial sync can be completed.

From there the app may be sufficiently stable to top off the syncs with 1 or 2 docs at a time without the same type of failure.

Bear in mind that this is second hand info from an intrepid enthusiast. I can’t vouch for its efficacy.

Always nice to see people enthusiastic about older issues :slight_smile:

Since DT added iCloud support I’ve moved over to that and it’s been working very well for me.

I am using port 7081 for WebDAV sync without any issues on a QNAP with actual firmware.

1 Like

I am under a constraint to avoid unsecured cloud storage.

FWIW, at the time my ‘workaround’ was to use standard port 80 which was blocked from outside. So I had my regular https access and could VPN in to sync with DT. Not perfect but it worked reasonably hassle-free, the iOS VPN setup works quite well.

1 Like

Thanks for the tip!