Issues with dark background and shortcuts in 3.1.1

A couple of issues I noticed in 3.1.1 (17082).

The app no longer remembers the “Use dark background” setting. I can enable it in settings and it will apply immediately. However, when I close the app (swipe it away) and relaunch, it disables the setting.

The shortcuts action “Find Items” does not return any results no matter the query or scope used. Same happens when using url commands to retrieve data - no results.

I have confirmed the first behavior and filed an issue on it.

I am seeing no issue with the Find Items action.

Please post a screen capture of the shortcut itself. Thanks.

Thanks Jim.

Maybe I’m not understanding the action properly.

Here’s a simple example DB called Test with three markdown docs:

Here’s a simple shortcut that I would expect to return the first and third documents:

  • Do you have another database or another group named test?
  • Have you rebooted this iOS device recently?

No other DB or groups named test. I tried with multiple groups in different DB with the same result.

I did try rebooting thinking it might solve the problem.

Remove the repeat loop.
Are there any reported results?

No results

If you haven’t already, try the search in DEVONthink To Go instead of via a Shortcut. What are the results? I’m guessing it’ll be none.

Searching in the app returns the expected results. E.g. the first and third docs per the example above.

Worth noting that I also ran the utility urls

I can confirm: the Find Item action doesn’t return a result.

1 Like