Item links in iOS 13 not working as they used to

Hi All,

I used to be able to open item links that I had copied into the desktop version of Omnifocus from within the iOS app and they would take me (via long press) to the matching document in Dttg. My life was great.
Now in iOS 13 this behavior has changed. When I do a long press in the iOS version of OmniFocus now, I get the choice to either copy the link or open it in Safari. If i choose the latter, nothing happens.
Am I missing anything? Is there a workaround or better way to make item links work in iOS?
Looking forward to your ideas and suggestions.

Here are pics to illustrate the issue…

Update: Just copied the link to iOS notes and tapped it there and it works fine. Seems to be an issue with Omnifocus on iOS then. Though I don’t think it has updated since my transition to iOS 13, and before it worked fine.

Does anyone have the same workflow and see the same behavior?

I’m not running OmniFocus on iOS, but on a side note: We don’t control what applications do with the URL or even if they support them. Support for specific URL schemes have to be added to applications by their developers.

When I long-press I get the copy/open contextual menu but when I just tap the link in OmniFocus it opens the corresponding document in DEVONthink To Go as expected. Does this work differently for you?

Hi All, Thanks for the info as to the implementation. I thought so.
But interestingly, when I just tap the link in iOS I get the cursor. So it does not open the link either, I just get to write into the notes field. But maybe you don’t put your item link in the notes field at all? Attachment? Title?
Very curious now.

Hi again,
I’m curious as to why the item links work with a single tap in your case. Do you copy the item links to the note section of Omnifocus in iOS?

I’m not in “edit mode” when it works, means: I have not placed the insertion caret into the text field first. I just visit the task, switch over to the Notes tab, and tap the link.

Very strange. I don’t think I’m in edit mode either. When I visit the task, switch over to the notes field and tap on the link, the insertion caret or cursor appears. I believe I have the most recent versions of both of the apps. I would upload a video of the process but video files are not allowed here. Do you have another idea what might be the issue?

I just tried it here. When I navigate to the task and directly tap the link it works. When I first tap next to the link it switched to edit mode. It’s a bit tricky what our friends over at Omni built there.

Well, thanks a lot for checking. Must be either a difference in hardware or maybe app version. It still does not work in my case. I can tap wherever I want and as fast or slow or hard or soft, I always get the same result: The blinking cursor. I’ll try and figure out a workaround of some kind then.
All the best.

I can confirm both @eboehnisch and your behaviour.

URL scheme in OmniFocus note field

  • short tap: opens corresponding document in DTTG
  • longer tap: opens iOS menu, clicking Safari item results in nothing
  • tapping beside the link: edit mode

I tried the same in iOS Notes and get the same behaviour, but in Notes the URL does work.

So for me, the trick is pressing short and light. Longer taps open the menu previously associated with 3D touch.

I think you’re better of at the OF forum, which happens to be a Discourse forum as well by the way :slight_smile:

Well, how frustrating. Thanks for confirming. Sadly, the trick still does not work in my case. And yes, I’ll try the Omniforum for this question.

Dear All,
For the sake of completeness: I found the problem. It is embarrassingly simple. I was using an outdated version of Omnifocus for iOS (2.x). I usually make a point of keeping my apps up to date, even more so if I am using them as heavily as Omnifocus and DT. How I could have missed the news about OF3 is beyond me.
Thanks again for all the help. Everything works as described above now.