Items disappeared from Inbox after creating an ecrypted database


I’m hoping someone can offer a little assistance. I’ve been adding documents to a single database now for several years. I decided last week that it would be a good idea to keep them in an encrypted database. I created one, then used the ‘Duplicate To’ to copy from my original database to the new encrypted version. This was fine, however I didn’t realize how big my database had become (10Gb). I know of course that I should have checked before creating the new one, but I didn’t. Anyhow, I scanned about 30 more documents into the new database and all seemed fine… Until I ran out of space and received an error. So, I created another encrypted database. Once again, since all seemed to work the first time, I used the ‘Duplicate To’ in the first encrypted database to populate the second. Two things happened. First, I now receive and error when opening the first encrypted database “Found 6 major file errors. Please restore the last backup or rebuild the database and verify the contents afterwards!”. I’ve tried restoring prior versions of this, but since it was new, and never closed when Time Machine backed up, it still fails. I’m less concerned about this than the second problem. I used to have a few hundred documents in my Inbox waiting for me to annotate, sort, move, etc. Now, there are no documents in my Inbox for any of the three databases including the first, unencrypted version. I maintain offsite backups which are done when DT3 is closed, so I’m confident I should be alright there. I’d really prefer not to restore a backup and have to re-do all the scanning since if there’s a way I can find out where my Inbox items went to?


Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks!

The global inbox or the local inbox of the encrypted database? Which maximum size did you use for the encrypted database?

What size did you specify when you created the encrypted database?

Thanks for the replies. I have sent a bug report. As for the Inboxes, the documents no longer appear in the original database, first encrypted database (10Gb) or the second encrypted (20Gb) database inboxes.

Properties show the original non-encrypted database to be about 10Gb, so it made sense after checking why I ran out of space in the first encrypted version.

My non-encrypted original database (per the database properties dialog box) has 142 smart groups, 1,234 groups, 1,059 rich texts, 808 images, 5,585 PDF’s. This all seems correct and the document counters in beside each category match.

The database properties for my Inbox shows 29 rich texts, 326 PDF’s, 13 unknown, 6 groups and 145 tags for a total of 526 items. This appears to be correct. When I click on the inbox (global or any individual inbox for any database), an Annotations smartgroup is at the top with only three documents below. Each of these I added after I started having problems. I’m not sure why there would be an Annotations smartgroup in my Inbox.

You could try this:

  1. Change the extension of the encrypted databases from .dtSparse to .sparseimage, then mount them in the Finder by double-clicking on them.

  2. Copy the .dtBase2 databases from the mounted volumes to the desktop and unmount the volumes again

  3. Try to open the .dtBase2 databases. What does File > Verify & Repair Database… report?

Thanks for the assistance.

There was an error that appeared, but then it moved on and rebuilt the database. It did not do this before, it only advised to restore the backup. From what I can see, the database seems complete. The inbox however did not change.

I also completed a verify and repair on the inbox(es) and it now shows 4 annotations and 87 orphaned files. When I look at the inbox properties, it still reports 614 total items. There are definitely many missing items from the roughly 400-500 I estimate existed initially. Some progress was made for sure, just not sure where to go next in regards to missing inbox items.

That’s weird as it seems to contain more items now. Are all databases now successfully verified? Did you search across all databases for the items which seem to be missing?

All databases did verify without a problem.

I’m not sure exactly which items are missing, as I generally scan many documents to the inbox. When I have time to look through them, I typically rename, sort, add tags and annotate before moving into a destination folder.

Is there any way to restore just the global (or other) inbox(es)? The databases themselves appear to contain the correct number of items. A cursory look suggests the contents are fine.

The local inboxes can’t be restored, the global inbox is just a special database (~/Library/Application Support/DEVONthink 3/Inbox.dtBase2) and depending on your Time Machine settings it might be possible to restore an older version.

I finally had a chance to get back at this. I move files from the global inbox to their final destination folder, so there would have been nothing in any of the local inboxes. Apparently, however, my Time Machine settings were not conducive to a restore. I did attempt this, but the global inbox still shows 4 annotations/87 orphaned files/3 normal files (scanned since the failure) even though I restored a version prior to creating the encrypted database and starting to have problems.

These are the Inbox properties. Is there anything else you can suggest?

The inbox contains a lot more stuff according to the screenshot.

Exactly. The properties screen shows what I expect to see. The list I provided is all that shows up in DT3 when viewing the Global Inbox. Most items shown in properties are missing, despite having tried to rebuild it and DT3 reporting the rebuild was successful.

Did you try to search for kind:any in the inbox? How many items are found and where are they located?

If I’m understanding correctly and type “kind:any” in the search box and specify to search in Inboxes, it finds 90 items. Most are in Inbox > Orphaned Files while 3 are just in Inbox.

Does File > Verify & Repair Database… report any issues?

Whether I perform this on the global inbox and my currently open database, both show “Successfully verified” in the log.

A screenshot of the sidebar showing the fully expanded inbox (including expanded subgroups) might be useful.

The items seem to be in the trash, the search doesn’t return trashed items.

I had considered that as well. When I scan documents, I always rename them immediately before they are saved in the global inbox. As I looked through the trash folder, the names of most documents are what they would have been named by ScanSnap as opposed to the naming convention I always use. So, I’m not sure why these appear this way and therefore had not associated them with all the ones that were renamed in the inbox.