L/ and O/ weird automatic hybrid characters!?

in a DTP RTF document, let’s say i wanted to type “all / none” but without the spaces.

wherever there’s an L and then a slash next to it (in that order), DTP automatically combines them into some weird hybrid character. same thing with O. i can’t figure out what the heck is going on or how to stop it. i recall having seen this same bizarre thing happen in another program too, but can’t remember which one(s).

it especially can become a problem when text you’re typing include URLs or file paths (that use slashes)


Does this happen in TextEdit for example too? Then this might be a “feature” of a third-party extension.

Nope, doesn’t happen in text edit.

Please enable the keyboard menu extra (via System Preferences > International > Keyboard Menu), then launch DEVONthink, pull down the keyboard menu and check which input method/keyboard is selected for DEVONthink. I assume it’s not the default one.

Okay, well it’s called “input menu” in the International preferences, but I think it’s what you’re talking about, and I enabled it in the menu bar.

Character Pallete was checked. I unchecked that. Didn’t make any difference.

Now the only input type that’s turned “on” is US keybaord Roman script. This is what’s being used for DTP, for Finder, for everything apparently. The weird problem persist.
I tried switching to US Extended Keyboard Unicode, but problem persists.

Oh yeah, and I’m on Mac OS X 10.4.8

What fonts are you using in Preferences > Editing?

Helvetica and Times, for example, are not likely to produce strange font effects.