Latest version of DTPO

Could someone tell me what the latest version of DTPO is? I have preferences set to check for updates daily, but the last check of at the beginning of the month. I’m currently running 2.9.8.


2.9.11 is the most current version. See Download page.

Thanks for the information. I don’t know why I’m not being updated. When I check for updates, either from the DEVONthinkProOffice menu or from preferences, I don’t get any feedback at all.

Any suggestions as to how to update? Can I just download the latest version from the download page and install that and have all my databases the same, or is that going to give me two installed versions?


It is strange that you don’t get a response. When I manually check for updates either DTPO tells me I am current or suggests an update with a button to do so.

What operating system are you using? If you are using an older system that does not support feature updates from DT that could explain the hold up.

I think you should wait for someone with better diagnostic skills. Perhaps a simple download of the update would do it, but I am not certain.

Thanks for the response. I’m using macOS Sierra, v. 10.12.4 which shouldn’t be a problem. Perhaps someone else with better diagnostic skills than we will see this and answer. I hesitate to download and reinstall without knowing for sure that that’s an ok route.

Thanks again.

I tried something and it worked. I quite DTPO – I usually have it running all the time. Then when I restarted it, I saw it say it was checking for updates and told me I had to quit Apple mail app, which I did, and then, after DPTO opened I checked the version and it was the latest, 2.9.11.

All’s well that ends well, I guess :smiley:

Sometimes a restart solves problems! True in many occasions, even beyond software. :wink: