Link Bug in 1.9.1?

I create a group. I create a rich text note. I drag my client list over from a rich text note that resulted from a document import (Word). I click at the beginning of the first line of the newly created client list, hit return to leave a blank line, then type in a more recent client that wasn’t yet in the list “Little River Band of Ottawa Indians, Manistee, MI” (without the quotes) in the blank line, hit return and type in another client, thus adding two new clients at the beginning of my client list.

I select the Little River Band client (I select the entire text in the quotes above) and click the “make link” button. I then click on the link and it makes a new note with the full name in the group. So far, so good. So I close the newly formed, linked note. Then I click on the link again, towards the right side of the link. This time it creates ANOTHER note, titled “River Band of Ottawa Indians, Manistee, MI” rather than opening the previously created note. If I click the left side it creates yet ANOTHER note, titled “Little.”

I’ve tried everything, including completely removing all the notes and starting over. It is 100% repeatable and aggravating because all I wanted to do was get my work done. Anyone seen anything like this before? Help please.



Try saving your RTF file each time after creating a new link. Works for me, and seems to be a critical step.

Bill, I appreciate the advice but it still doesn’t work. I saved the note immediately after making the link. I even added text to the new opened notes, saved them, closed them, then went back to the link. I believe it worked correctly once after this. Then when I clicked the link another time I got another new note, clicked the other end and get a second new note. It would seem the only workaround is to have a link that is only one word long, but that sort of sucks because I wanted the new note to have the full name.

I’ve even tried creating a new RTF first. Naming it. Copying it’s name and pasting it into the “home” RTF note. This creates the link that way. Click the newly formed link, same problem.

Once it has screwed up this way though it doesn’t create a 3rd and 4th one, just the original three (at least so far with limited testing). But the first one that was the desired one is inaccessible from the link. It always opens one or the other of the other two unwanted notes, depending on where the link is clicked. I’ve tried other client’s names too, and get the same result. It seems that something is seriously amiss here. I bought this program to enhance my productivity and, honestly, all it has done so far is detract (or distract) from it.

I guess I’ll do it in NoteTaker instead, but that is not what I was wanting to do. Sigh…



I’ve got hundreds of Wiki links, and they are working like a charm.

I can’t replicate your problem. In an RTF file I entered the phrase in your first posting, selected the phrase, used the contextual menu option to Make Link, pressed Command-S to save the RTF file in which I was working, then clicked first on the right side of the new link (result: the desired file opened), then clicked on the left side of the new link (the desired file opened).

My Preferences > Editing > has WikiLinks checked for Automatic, radio button set for Names and Aliases, checked for Don’t link to groups, and checked for Open new documents in separate windows.

Comment: Whenever something seems to go awry in DT, I run Tools > Verify & Repair. If there’s no error reported, I then run Backup & Optimize and quit DEVONthink.

If I haven’t done disk housekeeping lately, I run the cron scripts and repair preferences, followed by a restart. Sometimes, I just restart, on the theory that a bit in RAM might have gotten twiddled. Every week or two I run a routine to clean caches, run cron scripts and then run DiskWarrior to correct any directory errors.

Note: The betas of DEVONthink Pro have been extremely stable. I haven’t seen a Verify & Repair error in six months or more – and in that case running the routine a second time cleared up the problem. My database contains more than 13 million words and is growing.

Any time that I’ve been dumping lots of new content into DT and/or doing substantial writing/editing, at break time I run Verify & Repair, followed by Backup & Optimize. That way, I can revert to a very recent backup, if anything were to go wrong (I did have to do that last Spring).

By the way, I also use NoteTaker and like it. But DEVONthink is so much more powerful for finding and relating data that DT is where my data goes.


You said “I can’t replicate your problem. In an RTF file I entered the phrase in your first posting, selected the phrase, used the contextual menu option to Make Link, pressed Command-S to save the RTF file in which I was working, then clicked first on the right side of the new link (result: the desired file opened), then clicked on the left side of the new link (the desired file opened).” After you’ve done this, now close the note window then go click on the link again. How many words are you using for the link? I’m wondering if it is sensitive to the number of words in the link.

I checked what I had done in prefs, mine are set exactly the same as yours.

When I began having this problem earlier today I did the verify and repair routine. It found 3 memory errors (no other errors) and supposedly corrected them after which I did the backup and optimize. I quit and restared the program (after eliminating all the problem notes), checked verify again and it was OK. Remade the notes and links, with saving after making each link, just like you said, and I still had the same problem.

I too do all the routines such as repairing permissions (before every time I install a program and absolutely before an OS upgrade), run MacJanitor occasionally for the nightly, weekly, monthly servicing all at once, and run DiskWarrior if there is an apparent OS problem (DiskWarrior is a lifesaver but also a potentially dangerous program). I always bring up UNIX and run repairs using FSCK -F before running DiskWarrior, however.

So, basically, I’ve no idea why I’m having this problem. The finding and relating of data that you refer to with DT is precisely why I bought it. I thought it would be nice to finally catch up all my projects and relate them to all the reports I’ve written the past few years (for PR on website, etc.) but that is where the program is failing me, because I need the links to work to make it worthwhile to do in DT.


Here’s an example of properly working Wiki-links of notes from a “master” RTF document. The name of the file is “Wiki”.

I’ll keep it up on my .Mac account for a few weeks. Here’s the URL to download the example: … ring5.html

Download the file using Safari or your default browser. (NOTE: You can’t download the file from DT’s WebKit browser!) Then unZip the file by double-clicking it. You will see a folder named “Wiki example.”

Now, in DEVONthink, go to File > Import > Files and Folders. Select the folder “Wiki example”. This will result in a correspondingly named group in your DT database.

Double-click on the new group. Inside it, you will see a subgroup. Now double-click on that to open it in a new browser window. If there is a subgroup inside that, double-click on it to open a new browser window. Set the browser window to the Vertical Split view.

Select the file in this view, which contains several Wiki links to notes, and click on the links.

Note: This is also an example of how DT users can share information over the Internet. I used DT’s Files > Export > File and Folders, then archived the resulting folder so that it could easily be transported on the Internet (or emailed as an attachment). :slight_smile:

Seems that automatic links and links created by you (“Make Link”) are applied to different parts of the mentioned phrase and that this is causing the troubles. V1.9.2 will only add automatic links if there’s no other link yet. In the meantime, using only automatic or (!) manually created links should solve the problem.

Thanks for the info, the upgrade should fix my problem! For the time being I’ve turned off the automatic Wiki linking. Now that I’ve created the links with the Wiki turned off I’m wondering if it will mess them up if I turn it back on? I’m afraid to experiment with it since it’s working. Any idea yet on when the Pro version will be out? I’m still learning new stuff in 1.9.1 but if there are things in the Pro version that will make using it easier I’d rather learn it!


Automatic links don’t modify anything (they’re applied “on-the-fly”) and turning them on again shouldn’t cause any troubles (at least as soon as V1.9.2 will be available).

DT Pro will be available shortly after DEVONagent 1.5 (which will be hopefully released next week).

As you may remember, I just bought the DT/DA bundle a couple of weeks ago. Will DA 1.5 be a free upgrade or will there be a charge? I already know about the $35 upgrade fee for DTPro.


All 1.x releases will be free updates (although v1.5 will be a big revision - it’s my default browser :slight_smile:)

I am having the same problem as Chembob on DT Pro 1.0.1

If I create “Very long name document” and then I create another document and write on it “link to Very long name document” DT Pro underlines and changes the colour of the text when I save it, but when I click on the link it creates a new document with “Very long name” or “document” but it doesn’t link to “Very long name document anymore”.

I tried the suggestions to “Verify and Repair” and “Backup and Optimise” then disable and then enable wikilinks on the preferences and they work for a while, but then it doesn’t again…

Any other suggestions?? Anyone else with the same problem?

Automatic links are (especially if they’re not based on MashedWords) not always unique, e.g. you’re database probably contains an item named “document” too.

There are three possibilities to make them unique and/or improve things:

  • Select some text and choose “Make Link” or use the contextual menu command “Link To > …”
  • Use MashedWords
  • Disable linking to groups

Your example works fine over here in a new database - clicking on the link displays the “Verify long name document” document because the link is unique.

The automatic link is unique I just gave an example not a real one. But the you get the idea.

Making links does work, but defeats the purpose of automatic wikilinks.

I guess I could use MashedWords ButIFindThemDifficultToRead :wink:

I’ve always disable linking to groups.

I’ll give you a real example tomorrow when I’m more awake, but again the links are unique, that’s one thing that I made sure of.

Thanks for your interest :slight_smile:

Here is an example from my database:

“Keith Edward’s Building Consultancy” is the name of the file that I want to link to from another document called “Building Inspectors”.

In “Building Inspectors” I write “Keith Edward’s Building Consultancy” and save which underlines changes the colour of “Keith Edward’s Building Consultancy”. I Click on the link and it works, go for a wander come back, I go to click on my “Keith Edward’s Building Consultancy” link again and it creates a new document called “Keith Edward’s Building” or “Consultancy” depending on where I click on the link. I have checked and I don’t have any documents or records called “Keith Edward’s Building” or “Consultancy”.

I hope this is useful to solve this issue.

I’m with you. I DontLikeMashedWordsBecauseTheyAreHardToRead. :slight_smile:

But when setting Automatic Wiki Links to the names of documents, it’s really critical that there be no typos, extras spaces, etc. It’s also critical that there not be any existing document with a name that’s a subset of my Wiki link text string.

If I’ve typed a document name to establish a Wiki link, I test if. If it works, I press Command-S to save the document right then and there.

If instead of linking properly I accidentally create a coupe of unwanted documents, I mutter to myself, delete the unwanted documents and the bad link. Then I may open the document to which I want to link, Show Info and copy the name to the clipboard and paste it where I want to establish the Wiki link in my current document. That usually works.

Actually, I’ll confess that I don’t use Wiki links that often. Reason: I usually don’t want to have to type out a document name in my text, but want to refer to the other document within my text. E.g., I want to make the string Keith Edward the link string, instead of typing out Keith Edward’s Building Consultancy. So I select “Keith Edward” and use the contextual menu option to establish my link to the document that’s referred to.

Activating Automatic Wiki links can somewhat slow down a really big database, so I may turn it off when I’m running the database through hoops. That’s why I prefer static links, as they always work, even when I’ve turned off the Wiki link feature. I’m often forgetful. :slight_smile:

Thanks Bill, I am considering not using automatic wikilinks. We’ll see…