Link To ... Results Are Not interactive

I discovered a problem. I don’t know if It’s a bug or my misunderstanding of what I am doing? In my daily use of DTPO I have a Rich Text document at the top level of a dozen smart folders, each dedicated to a project I am working on. When I look at that document I see a list that I read through to see my tasks to be done. For me It Isn’t enough to know that I have to do the task, I Want to be able to easily find the document when I am reminded. What better way than to put a link to the document I have to work on, on the text that tells of of the task?

If a task has to do with editing a document, I attach a link to that text, right click, select “link to” and follow the menus through “inbox” to the folder, to the document I have to work on. I was thinking this is a great idea, until this morning when I had time to work on something and I discovered that, the link shows the document, but that’s all. There appears to be no way to actually open the linked document. It is a linked Word file but even if It were text there is no way to interact with the linked document. Normally when I have something in DTPO’s screen and I can see It, I can also open It (all my files are indexed).

Is this a bug, or was It designed this way? Why link to a file in DTPO and have It display but not be clickable? :cry:

I use this feature all the time, and it works as you are expecting it should work. I don’t know what to suggest you try, but perhaps quitting DEVONthink and restarting your Mac would be the first thing to try.

No, I just did that after your reply. Same results. Perhaps a tech support person will see this and take up the cause? I am glad that It works for you, seemed like a good idea at the time.

If you need a response from tech support, it’s best to open a support ticket.

OK, thanks. Right now I am re-indexing and then rebuilding the DTPO database in case that helps. Once that is done if the problem is still there I will send this to tech support. Result: No Change!

I use the old Mail style window with the folder list on the left and the contents of the folder on the upper top/right and the results of any Item below on the bottom. BTW, when I click on a link, I get the linked document, but I cannot right click on It and there is no link above the document.

When I show the same document in It’s smart folder I can right click on It, launch It, etc. Just to be clear when I write to tech support, You are saying this is the same for you in the link to feature?


What you are describing has nothing to do with the linking feature of DEVONthink.

There is a difference between right-clicking on a document, and right-clicking on the Quick Look view window/content of a document. There are some document types (HTML, PDF, text, etc.) that you can right-click on the document and get a menu of action choices, and also right-click on the Quick Look view window/content of a document and get another menu of action choices. As example, right-clicking in the Quick Look view window/content of an HTML document:

However, there are other document types that you can right-click on the document and get a menu of action choices, but right-clicking in the Quick Look view window/content of a document does nothing as DEVONthink cannot work with the document type. As example, here is an iThoughts document that I can right-click on the document in the Three Pane view and I have options. However, If I were to right-click in the Quick Look view window/content of this document, nothing happens:

Experiment with some text or PDF documents and see if right-clicking in the Quick Look view window/content of the document works.

Yes, I understand. I Was a little unclear, sorry about that. You are right, clicking or right clicking on what is displayed yields no results anywhere. However, the smart folder file has that file in It’s list so clicking on that file name in the list does launch that file.

Going further, I changed my text link to the smart folder so I could at least easily find the file I was working on. Double clicking on the Word document in that view yields a spinning grey mac-flower-thingy forever. However, right clicking on the same Word Icon and selecting open with Word, opens the document almost instantly.

Weird. :unamused:

You can always reveal a document when active by typing command-r.

You can always open a document when active in its native app by typing command-shift-o

Excellent suggestions. Thank you. I am still learning a LOT about this program. :smiley: