Lion autosave locking a pdf within DTPO?

I’ve just experienced this rather unwelcome behaviour - I’m wondering if it’s anything to do with Lion auto-save/versioning and if so, how I can stop it happening again.

I have a pdf which I had highlighted before in DTPO. Today I tried to add more highlights to it in DTPO and it wouldn’t let me. The pdf wasn’t locked inside DTPO and there was no sign that there was anything untoward. When I opened it in Preview from within DTPO, and tried to add highlights, I got the dialogue box saying that it was locked because it hadn’t been used for more than two weeks and did I want to unlock it? Once I’d said yes, I could make the highlights, and these changes came through in DTPO in the normal way. I could also make further highlights from within DTPO.

I can’t actually remember whether I made the original highlights in Preview, nor whether I did so after I installed Lion, but I assume both are the case because I can’t think how else I would get this message.

But this seems to imply that, effectively, once you’ve highlighted a document in Preview, after two weeks you can never subsequently annotate it in DTP without first visiting the file in Preview and unlocking it.

Have I missed anything obvious here?

It is due to Lion’s Auto Save function, and if you are as annoyed by this as I am, it can be turned off. Go to System Preferences>Time Machine options and uncheck the Lock Documents option.

Thanks Greg,

I was wondering whether there was another solution - but turning off lock it is… I actually find the autosave function more of an irritant than a help in the way it’s been implemented anyway. Scrivener and other programs manage to do it without all the fuss…

Thanks again