Log window

How do I get the Log window to stop popping up all the time? I really don’t need to see it.

I recall there’s a setting for this somewhere, but I’ve been unable to find it.


No setting. Can’t be gotten rid of. It’s a “feature” :frowning: Maybe, use the Mac standard cmd-w to close unwanted windows.

If you are doing a lot of importing/indexing/synchronizing and causing the window to open, just put the log window in the background behind your DT window(s) - it usually doesn’t take the focus that way - and leave it alone.

I’m curious what are you doing that’s causing the Log window to pop up “all the time”.

I run my apps full screen and the log in window synchronizing pop-up behavior is a constant annoyance. It takes my focus away from my work multiple times every hour. I want a different design for this, please.

Unless I’ve misunderstood what the problem is, doesn’t the ‘Show Log Automatically’ checkbox control this? (On the bottom of the log window itself).

When I have this unchecked, I never see the Log window unless I ask for it. When it’s checked, the window pops up whenever it records something.

I’ve misunderstood, haven’t I…

I believe the window being referred to is actually the Activity window, which does have a nasty habit of pulling the user to different Desktops when it appears at sync time.

There is a hidden preference in DEVONthink’s documentation that prevents the Activity window from showing up. This was a lifesaver for me.

Yes, indeed, it is the activity window that is popping up multiple times an hour and taking my focus away from my full-screen DT app. I’ve been searching for the hidden option in the manual to turn it off but haven’t found it. Can someone give me a pointer?

Thank you.

Check out the Help > Documentation > Appendix > Hidden Preferences

has DisableActivityWindow.

Or you can paste this link into Safari: