Lost connection error message

After 1.1 if I stop a synch because it has frozen and then restart I always get an error message about a lost connection. 1.1 Simply. Does. Not. Work. It won’t synch anything and constantly stalls. Further, after the update it wouldn’t load and I had to remove it and reinstall. Now I can’t get any synch to go for more than 6-10 items before it stalls.

So go to iTunes and get 1.1.1.

I have. The problem I am having is with 1.1.1.

Sync with DT TG has been reliable here.

Stalling is another matter. Look at the progress pane. Do you see the name of the same document every time a stall happens? If so, it’s probably a ‘strange’ file. Removing that file from the database, or opening it and saving a copy - then replacing the original with the copy - may allow sync to go to completion.

Recently a user sent via a Support query a jpeg file that always stopped sync. I confirmed that. Then the jpeg was opened in Preview and File > Save As was used to save the copy to the Inbox place in the Finder, sending it to the Global Inbox. The original was then deleted and replaced by the copy. Sync then worked without a stall.

The user had received four JPEGs all of which stalled Sync. Replacing them with copies created by Preview solved the problem.

Either the application that created the original JPEGs created malformed files or something had happened to damage them.

If you find that a file is stalling Sync, please send a message to Support referencing this forum thread, and attach a zipped copy of the file.

The stalls happen on all of my databases. None of them has documents in them. They are solely indexed databases. The stalls happen after only a few items are synced. Sometimes it stalls on a folder name. Sometimes it stalls on a file. It doesn’t matter whether the database is small or large. None sync. I will delete the databases, rebuild them and try with fresh ones to see if that has any effect.

Btw, Settings > DEVONthink still displays 1.1 after installing 1.1.1: