Mail 7/Mavericks: Plugin not showing in Mail (no menu items)

I installed DTP 7.1 and installed the Add-Ons which work as expected in Safari but not in Mail: There is no entry “Send to DevonThink” in the mailbox or the message menu.

Tried the UUID method posted here in forums but it was already there. The plugin gets copied to ~/Library/Mail/bundles but seems to do nothing.

Any hints?

Okay here. I have 4 Mail related scripts at the bottom of the script menu.

@Allsop: you are right: I have these entries too. Didn’t notice them before.

Although I have these script entries I was looking for menu items, as in a previous version I tried they have been at Mailbox/Email Menus named “Add … to DevonThink”.

Looking through the documentation I understand there is a Plugin and there are Scripts for Apple Mail, both doing the same.

The Plugin should be preferred because it is more efficient:

So this is what I am missing.

The Mail plugin is only in DEVONthink Pro Office. The plugin is compatible with Mavericks. Note that Apple “kicks out” all Mail plugins when an OS X update or upgrades is installed. If that happens, run the Install Add-Ons procedure to reinstall the plugin.

I also have the plugin but hadn’t realized it was a plugin :blush: Menu>Message>Add to DEVONthink Pro Office.

Just got the solution from Devonthink support (Ch. Grunenberg):

please enter this (without quotes) in the Terminal…

defaults write EnableBundles -bool TRUE


...while Apple Mail isn't running.

This solved my problem.
Thanks for the great support! :smiley:

Thank you very much! Was about to pull the last of my hair out when I saw your post. DTPRO and Mail 7 are now working for me.