Mail not moving into DT3

I have updated my Mac OS to 15.3 recently and also DT to 3.03 all seemed well but when I tried to send email from Mail to DT3 nothing moved it just reported 0. Print to DT3 works fine otherwise it just does nothing something appears broken in DT 3.03 or 15.3? disc permissions looks fine

Seems to have resolved itself now and I did nothing add to DT3 was not working!

The mysteries of computing. :slight_smile:

1 Like


Haha! Time to clean my glasses, @sjk
(No seriously. These things are fillthy! :stuck_out_tongue: )

1 Like

I seem to run into exactly the same issue.

Most recent macOS, clean installation, most recent DT3, full disk rights, mail drag and drop works, import from DT3 works, mail plugin installed and enabled…

… but pushing mail from Mail to DT3 results in 0 moved mails.

AFAIK I’ve done nothing different compared to another macOS installation where pushing mails from Mail to DT3 did work. Haven’t tested that again recently though. One difference I noticed was that disk rights were asked automatically on the working Mac, but had to be set manually on the non-working Mac.

I am afraid I can’t explain this but when it happened I got a report saying 0 mails moved. I tried this a few times and each time with different e mails the same. Then I reported the problem and after a while maybe 45Min returned to the issues and it had resolved itself. I did nothing. Since this problem everything is OK and everything works fine I assumed it was me being dum?

I don’t know if it helps I did do one thing, that was to double check, as I had updated DT3. that I still had full disc access and that was still set as it was previously. Maybe by checking in a weird way it was rebooted although I never changed anything as it was all set correctly.

If you’re running Catalina, it’s even hard to say what may or may not have happened.

I had the same issue with trying to import via Mail under Catalina.

However, when I dragged the email across to DT, I was prompted to allow permissions which I accepted and the mail imported. From that point on I was able to import directly from the Messages drop down in Mail.

Hmm… I could drag an drop without a problem. Also importing (“pulling”) mail from Mail with DT works without issues.

It’s only that pushing from Mail to DT3 with the plugin doesn’t work. I get the same report (0 mails moved). Strangely enough this is a problem on one Mac, but not on another. And AFAIK I didn’t do anything different after installing DT3 and setting up my mail-accounts.

Perhaps the order in which permissions are given is critical?

@BLUEFROG What do you think, does this qualify as a bug report with three users independently reporting it? It’s sketchy as I cannot reproduce it I think, unless perhaps I reinstall macOS and try again.

What’s actually selected and do you use Mailbox > Add to DEVONthink 3 or Message > Add to DEVONthink 3 ?

Good one, I think you solved the mystery @DavidSparkes and @donmc123 faced as well.

I used Mailbox > Add to DEVONthink 3, which doesn’t work from the Inbox in Mail. But Message > Add to DEVONthink 3 does work from the Inbox

I then tried to push a separate mailbox (different from the Mail Inbox), which pushed the messages without a problem.

To conclude: don’t use Mailbox > Add to DEVONthink 3 to push the Inbox to DT3. Is this default behavior?

Edit: the same goes for the Bin mailbox. That won’t work. So it seems to be the contents of “special” mailboxes in Mail that cannot be pushed to DT3

Yes, this command doesn’t support the inbox. Only real mailboxes are supported (e.g. local ones created by the user).

OK, user error apparently.

Is there a way to detect the mailbox that mails are being pushed from?

This could enhance the user feedback. E.g. instead of “0 moved” -> “You cannot import Inbox”?

Or even better, a greyed out option in Mail when the special boxes are selected?

To be clear, I certainly wouldn’t ask that if it was only me :), but there appear to be at least three independent users making the same mistake.

I was actually wrong, I’m sorry - the inbox is supported. Just tested this by using Mailbox > Add to DEVONthink 3 both for the selected inbox and an IMAP account inside the inbox. What kind of account(s) do you use?

I see the same behavior with a Gmail account in Apple Mail.
Select the Inbox, Mailbox > Add to DEVONthink 3 = 0 emails imported. This is into a database with no emails ever imported.

Nothing logged to DEVONthink’s Console.

And IMAP? Does this work like on my machine?

Sorry, it’s iCloud which is listed as an IMAP account. It’s just a Gmail address.

Just tried iCloud successfully too. The only obvious difference is that I use several accounts (POP3, IMAP, iCloud, Gmail). Which macOS version do you use?