MAJOR MAIL IMPORT ISSUE - Empty image attachments

Hello, since the last update (using Yosemite BTW) when I import my emails (as I’ve done for ages, I keep a database per client) I end up with the image attachment weighing zero k… so their icons are there but the image files are emtpy.


PS: Needless to say it makes me look silly as I have to ask my clients to resent their mails with the images… nothing less professional than someone who loses content.


Am I the only one experiencing this ?!

H E L P

In DEVONthink Pro Office Preferences > Email, check the option,”Download remote images in HTML messages”. If that option isn’t checked, the remote images won’t be included in captured email messages. That works for the current version of the DEVONthink application running under OS X 10.9.5. My email captures do include images.

Does that Preferences option work for the current version of DEVONthink Pro Office under a prerelease of Yosemite? I would suppose it does, but as I’ve got an on-going project I won’t upgrade to Yosemite until after the official release.

More generally, Apple noted that the public betas of Yosemite weren’t intended for mission-critical work. While those betas introduced new features to OS X, they have also included a number of bugs, so that there have been changes in the several beta prereleases of Yosemite. At least two “Gold Master” releases have been made to developers. Will the official release include still more changes and bug fixes in Yosemite? We’ll only find out then. :slight_smile:

I upgraded to Yosemite several days ago without impact on DTP. However, today all my emails are only displayed as Outlook icons (which I don’t use - I prefer Mail).

I can find no preference settings that might be the culprit but with the thousands of emails on client files, I need access to the emails.

DEVONthink does not control this – DEVONthink uses the icon assigned to files of a particular type by OS X. The icon is usually assigned based on the program that OS X assigns to that file type as the “open with” application. For various reasons, OS X sometimes changes the “open with” assignment – as a result the icon for that kind of file gets changed system wide.

The fix for this done in Finder. In Finder, select a .eml file and choose File > Get Info or command-i (⌘-I). Look for the control in Finder’s Get Info shown in the image. Click the dropdown box and choose Mail. Click “Change All”. Finder will ask “Are you Sure”. Say yes.

The image is Mavericks Finder – the idea is the same in Yosemite.

To “select an .eml” file I suggest dragging a message out of Mail to the Desktop, rather than mucking around inside the DEVONthink database. It doesn’t matter where the .eml file is located when you make this change. If Finder already has “Mail” assigned to .eml files, then change the assignment to something else and back to Mail. It can take OS X a while to update icons – and sometimes it is necessary to reboot after changing the Open With assignment, and also quit and restart DEVONthink.

One of the causes of this problem is a “rogue” program that will change this system-wide setting without asking. Outlook is one of those programs. If you are not going to use Outlook, uninstall it to remove it as a candidate for “open with”.

Thanks Korm.

You also solved another issue - the default program for opening an email from within DPO - I suddenly realised the solution as soon as I saw your reply!