.manifest missing of database error on one device only

I have this error on my iPhone only, no idea what it means or why it is only one one device. I’ve searched in Devonthink on my Mac and couldn’t find any file this might be referring too.

1 Like

This could be a temporary issue (depending on concurrent activity of other devices), is a verification of the sync store successful?

I have verified everything and no errors come up so should be all good then, probably a small bug or something?

Just a temporary issue due to conflicts, as long as the sync store is verified successfully, it’s harmless.

1 Like

FWIW, I had a similar experience today. It has not impacted functionality.

Did a verification of the sync store report any persistent issues?

I got this again today but only on my iPhone. Again doesn’t seem to be causing any issue from what I can see.

And the verification is successful or not? You can verify the sync store also on the Mac in Preferences > Sync via the contextual menu.

I just started having this issue, and when I verified my database, I got a “Broken or not yet complete data structure of database” message. Should I clean the database and start from scratch?

I started getting these errors this morning, about an hour after I received a “NSIRD_DEVONthink_t9BJKW” message (I didn’t notice this at first, but then found it in the log).

Where are you seeing this message?

Yes you should clean the sync data.

I saw this in the log on DTTG 3. It’s not in the log on DT3.

I’ll clear the sync data right away, thanks.

If you see the message again, please post a screen capture. Thanks!

Thanks for the screencap. That’s very informative!

Please open a support ticket and attach that screencap.

Will do!

Has this problem been solved? I have the same problem now.

I haven’t seen this issue again since I last reported it

I thought I solved my problems by cleaning the sync locations and starting all over. After a few weeks the error messages appear again.

I have DT 3 on the Mac and DTTG on iPhone and iPad. All latest models and OS versions.

@BLUEFROG et. al. I’m starting to get very confused. Exactly what triggers this message? Is it really serious? Does it stop sync? Or how does it interfere with sync? Just because the message is posted, what is someone supposed to do about it (besides post here?). And if missing, can’t DEVONthink re-create it?

(I sometimes see it and then it disappears and I give it no cause for concern and move on with life, but …).

That’ not possible. But the sync actually verifies each uploaded manifest (independent of the settings or type of the sync location) immediately by downloading it again, therefore it’s unclear unfortunately currently what’s causing this and whether this is a CloudKit issue as we couldn’t reproduce this so far.