Markdown not in color

I want to syntax highlight code in my markdown document. I tried the following but don’t see any colors in the preview. I also tried a language-applescript example but still the same result. Any idea why the preview is not in color?


Did you enable Prism in Preferences > Files > Markdown?

That did the trick! Thanks

Is this from the 3.5 release notes still true?

Markdown documents containing computer code receive syntax coloring for AppleScript, Objective-C, Swift, C, C++, Java, and JavaScript.

I need SQL formatting and language-sql is working without me having to resort to adding the full Prism files to the database with the links as described in a post in this forum. Were more languages added to 3.8?

Several releases extended the Prism support since version 3.5.


How do I install Prism Plugins? Specifically I want to install the Copy to Clipboard plugin. I tried following the instructions on this thread to use a custom Prism JS / CSS but it’s not taking effect. See attached screenshot.

Any pointers would be appreciated.


DEVONthink doesn’t support this. If you want to use your own Prism JavaScript/CSS files, you would have to specify them in Preferences > Files > Markdown and to disable the integrated Prism support.

I just tried it and the preview shows blank and I don’t see any messages in the log console either. Any suggestions?


Convert the file to HTML and open the result in your favorite browser. Its developer console should tell you what’s wrong.

Assuming you checked off the plugin you wanted and created a new .js & css file, replace the quotes in the link href and script from an open / close quote to general quotes " " by retyping the quotes.

I was able to get it to work but I had to specify the custom Prism css and JS under Preferences and include the links to the CSS and JS in the markdown. See attached. Is this expected? I was expecting that only specifying it in the Preferences would result in these files being included in the markdown.

The CSS file can stay under Preferences but for every markdown file, you’ll need the <script src… link. (The preferences only loads the CSS and JS file on opening Devonthink but to use some plugins, it requires the code run on file load) You can probably setup a markdown template. I use a text expander so that all I have to do is type 3 characters and it’ll put the .js address at the top. MacOS has this functionality under System Preferences>Keyboard>Text

1 Like

Confirmed that the markdown only needs the script declaration andCSS gets picked up from the Preferences. I might just have CSS and JS declared in markdown given that JS is needed anyway.

I have aText and I created an expander definition such that when I type “dsql” in application DEVONThink, it expands to add the script declaration, language-sql and clipboard. This works in the DT menubar quick add markdown too. I have a similar one for java.