MathJax not work?

I checked Enable MathJAX support in the preference, restarted DEVONthink, but in the Preview view the following markdown

$$ \sin{\dfrac{\Pi}{2}x} $$

was rendered as it is in the Edit view.

Do I have to use some other markup to wrap the MathJAX content?

The source view doesn’t support syntax highlighting or MathJAX, only the preview should render it.

I was saying that, in the Preview view the markdown was rendered as the same in the Edit view, that is no special rendering.

Sorry, my mistake. We’ll check this.

Just tried this successfully:

Is your computer online? Do you use firewalls or LittleSnitch to block certain traffic? Because the MathJAX support is loaded from the web.

I guess that should be the case, my Mac is online, however some traffic may be filtered by my ISP, I thought the js is embedded in DT3.

Anyway to customize the URL of MathJAX or set manually(like the CSS)?

BTW, does DT3 honor the system-wide proxy(specifically Auto Proxy Discovery) whiling loading the js of MathJAX? I had it set, guess no luck.

You could insert this at the beginning of the document:

<script src=""></script>

<script type="text/javascript" src=""></script>

Can I do something equivalent to this at the DT3 level instead of the document level?

No. But does this actually work? Because that’s in the end what the MathJAX option does.

No it doesn’t work.

I tried the URL in Safari, the JS(and the JS URL within the JS) could be loaded successfully, maybe it’s not network related.

Could you please post screenshots of Preferences > Web and Preferences > Media? Thanks.

Should I enable JavaScript in the Web for the markdown rendering to work?

Yes, JavaScript is required.

I did, but still no luck, both with and without the <script> you provided above

Does it work after enabling JavaScript and restarting the app?

Just did a restart, and works now, thank you!


Here’s another issue about MathJAX in DT3.

The \\ seems to be escaped into \ in markdown

In DT3

on MathJAX

The pop-up is the result of this:

BTW, the exported HTML contains two script elements with identical src, is it expected?

<script src=''></script>
<script type="text/javascript" src=""></script>

It’s probably a redundant relict, I’ll check this.

@cgrunenberg Any clue about the handling of slash within the MathJAX block?